Various issues after rebuilding


(Mihir) #1

I installed discourse on a subdirectory recently, everything seemed fine. After rebuilding it, I have started facing various issues. I tried rebuilding again, with no success.

  1. Images (logo) went missing - returns 404. Even trying to reupload through setup wizard fails. It does not upload anything.
  2. Images on setup wizard does not display (like the images for dark/light theme, among others)
  3. Setup wizard redirects to incorrect location, it automatically redirects to this URL - https://domain.com/dir/wizard/wizard

I had followed the guide article for subdirectory install and everything was fine until I rebuilt. I rebuilt to update SMTP settings, which I am sure can’t be responsible for breaking these things.


(Jeff Atwood) #2

Do you really need a subfolder install? It is substantially more complex and harder to troubleshoot. We recommend against it, and we only support that install on our enterprise hosting, with an additional fee.


(Mihir) #3

I kinda have to, I need to stuff a keyword in the URL and this seems to be the easiest way to do so. Rewriting url structure is much more difficult.

I tried this setup twice. Faced the same issue first time, I thought I made a mistake so deleted entire VPS and started over. Still the same.

If you could provide a hint on what could cause this issue or what logs to check, that would be very helpful. I’m a developer but have no experience with Ruby.