We cannot detect if your account was created, please ensure you have cookies enabled

I’m fine with helping plugin makers fix their broken plugins, if we have specifics. Mostly we’d be providing them a repro so they can make changes to their plugin.

2 Likes

My general fix for this is to add autocomplete: discourse but I don’t think this is correct in this case.

This is actually not exactly the same as this broken chrome behavior: Issue 587466 - chromium - An open-source project to help move the web forward. - Monorail

Somehow, some extension is adding text to new-account-challenge after we explicitly set it from here: discourse/create-account.js.es6 at 6de254f64263d7e3cc223404348c03e23c85d904 · discourse/discourse · GitHub

This is clearly bad browser extension behavior to me. Why is it touching an INPUT after it already has text in it?

I am not sure there is anything we can do here short of isolate what browser extension is causing this and raising an issue with the authors of said extension.

6 Likes

I reproduced this with all plugins disabled before reporting.
I cannot reproduce it on a clean download of Chrome. Not sure if that is the lack of plugins, lack of stored passwords, changed settings or something else.

I wasn’t asking for more work to be done, I was trying to help find a tricky bug that has been reported by multiple people.

2 Likes

I really need some sort of repro here to be able to make any headway here

Without a repro we have no way of getting to the bottom of this. Chrome starting with version 48 or so went all user hostile with an atomic autocomplete non compliant implementation, maybe you managed to trigger something here

We just need a clean repro here to be able to move forward

3 Likes

I tried for an hour or so with a new download of Chrome; couldn’t trigger it on meta.

For our Discourse instance, I’ll change the “please ensure you have cookies enabled” to “Please delete any saved passwords and try again”; that should cover the rare occasion that someone tries to sign up, while already having a saved password.

2 Likes

If you can repro with a clean Chrome I guarantee you we will do whatever it takes to fix this. 100% guarantee.

I am intensely interested in ensuring that things work on default popular browsers. That is mission critical.

10 Likes

We’ve got the same issue. Here’s what they messaged us:

I would, but it seems like registration might be bugged. Everytime I try to register, I get a “We cannot detect if your account was created, please ensure you have cookies enabled.” error message, and no account confirmation email.

1 Like

Can you share a link of that instance where it can be reproduced every time?

1 Like

See earlier posts. Have them try with plugins disabled, or in browser safe mode.

Already read every post. Just for the record, the same person was able to register before, but since they did at an early stage, we deleted their account and ask them to re-join today. We haven’t added any new plugins since then.

That referred to browser plugins, it’s likely to be something in their browser altering the page.

1 Like

Pretty unlikely, since they received an email yesterday, with the exact same forum configuration. They also confirmed that they haven’t installed any browser plugins.

Can you repro it here on meta or on try.discourse.org?

Sorry, but I have no idea what that means.

Can the user reproduce (repro) the issue signing up on this site, or at try.discourse.org ?

1 Like

Probably only if the user already has an account with saved password on try.discourse.org
My symptoms disappeared the moment I deleted the saved passwords (this also explains why incognito mode works).

So you can repro this is a clean install of Chrome with no plugins on try.discourse.org? I am unclear. If you can, please list the steps so we can also repro.

I just tried saving passwords in chrome for meta and signing up with a new account. I didn’t run into any issues.

Did you try signing in, deleting the account, then signing in again in the same incognito session?

I don’t run Chrome, so I wasn’t in incognito. Here’s what I did:

  • Signed in with my normal Meta account
  • Saved PW in Chrome
  • Signed out
  • Attempted to sign up with new email
5 Likes