2.2.3 Broken images and JS errors


(Vincent) #1

Just updated from 2.2.2 (self hosted, upgrade started via web interface, selected upgrade all) to 2.2.3 has broken images and caused some js errors

Uncaught Error: Could not find module `discourse/helpers/topic-status-icons` imported from `discourse/plugins/discourse-solved/discourse/initializers/extend-for-solved-button`
    at o (ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18)
    at i (ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18)
    at o.module.exports.p.(/forums/anonymous function) (https://www.finalbuilder.com/forums/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:15997)
    at e (ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18)
    at require (ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18)
    at application-6157201f89cbc41715dde34af85ed4c9d799cece2e11aac8f0710af120c2affd.js:7
    at Array.forEach (<anonymous>)
    at n.start (application-6157201f89cbc41715dde34af85ed4c9d799cece2e11aac8f0710af120c2affd.js:7)
    at preload-application-data-0a59ccab480941aaac91f9e7fa7f77496323ae056aaa4158822dea35de319c01.js:1
    at preload-application-data-0a59ccab480941aaac91f9e7fa7f77496323ae056aaa4158822dea35de319c01.js:1

I tried rebuilding the container but so far no joy.


(Sam Saffron) #2

@vinothkannans can you have a look?


(Vincent) #4

I rebuilt the container a second time, same result. Seems like icons etc are missing


(Vincent) #5

Also none of our header customisations are showing, should be a bunch of links across the top which match the rest of our website.


(Yang.Y) #6

Exact same problem, icons are missing, JS error occurs, no luck in Safari nor in Firefox:


(Sam Saffron) #7

Are you on tests-passed or beta? can you flick to tests-passed and do a rebuild?


(Vinoth Kannan) #8

I think they’re in stable. It doesn’t have required Ember helper file.


(Sam Saffron) #10

Is there any easy way to make this cross compatible?


(Vinoth Kannan) #11

I can add the helper file in stable. It will not break the UI. And it will not add the feature too.


(Sam Saffron) #12

Sure… go for it, we need it fixed. No need to back port the whole feature.


(Vinoth Kannan) #13

It’s fixed here. @vincentp & @yangyubo can you please do the upgrade.


(Yang.Y) #14

Problem goes away after do the upgrade, thanks!

FYI, we are on stable, and tried a rebuild as we found icons were missing.


(Vincent) #15

@vinothkannans Thanks, that fixes it!


(Sam Saffron) closed #16