Icons not visible after installing Discourse 2.2.0 on Ubuntu 16.04

After installing Discourse 2.2.0 on server Ubuntu 16.04, I am surprised to not see the icons on the menu bar (for ex. the search icon)


How to fix this? Thanks a lot


Have you tried rebuilding? Are there any console errors in the log?


yes, we rebuild.
Uncaught Error: Could not find module discourse/helpers/topic-status-icons imported from discourse/plugins/discourse-solved/discourse/initializers/extend-for-solved-button

Ah, that’s an issue unrelated to the OP: the discourse-solved plugin is trying to load a helper that is missing from your core. You should upgrade to latest (or, unrecommended, downgrade the discourse-solved plugin).


Thanks for your help Penar, we were able to fix the issue by using discourse-solved plugin from Feb. 19 (commit: 3b7baa1a513e5267d8213ceda09dd461f94cf9ad) with Discourse 2.2.0.

If we rebuild discourse with latest commit of the discourse-solved plugin, which version of Discourse do we need to take to avoid this issue? version 2.3.0? We don’t want to upgrade discourse to latest if this issue is not fixed.


This was added on this commit, which is included in the latest beta. You should consider using tests-passed, you’ll run into less incompatibility issues if you do.


Ok Penar, good to know that it is fixed in latest beta of discourse.:grinning: