443 address already in use? Letencrypt

It used to work before on port 80 with my other website. I don’t remember how I set it up exactly but now I follow guide to setup Let’s encrypt and it only make change to like 3 line and when I run ./launcher rebuild app, I got errors saying that the 443 is already in use???

From google result, they require to turn off that 443 but that 443 is already serve by my main website. Like I’ve mentioned, I used to get the port 80 errors before the let’s encrypt and I don’t remember what I’m doing to fix the problem with dicourse + my website.

If you’re running another site on port 443, you can’t have your discourse site listening on the same port.

1 Like

Then what should I do? I’m not a sysadmin and even trying to find result on google is hard because half of what I found is not understandable. I know I need to add something to my nginx discourse block.

If it was working before, then leave discourse alone and just follow whatever instructions you want for enabling let’s encrypt.

But it’s a job for a system administrator. Either you are one, or you aren’t.

What tutorial can you point me to? Or is there a way to bind it to other port or do something else?

If you wondering what message I got, it’s 502 bad gate way.

We’re a startup and hiring someone with good knowledge of Linux but it’s hard to find so as a Developer, I need configure server myself to get thing up and running as soon as possible.

So this has never worked with discourse.

The easiest solution is to run discourse on its own server. If you don’t want that, search here for… This How to set up Discourse on a server with existing Apache sites

And if you want to hire someone to solve your discourse problems, I’m available, though I’m mostly on vacation this week.