502: Bad Gateway after web update

So ran updates this morning from the web interface and during the update of Discourse (not docker) it said that the update failed. I look at the log display but it really doesn’t mean much to me. I then ssh in and ran ‘cd /var/discourse’ then ‘git pull’ and ‘./launcher rebuild app’. After everything completed the site resolves with a 502 Bad Gateway. (http://forums.nyheritage.org/ btw). I’ve read through the similar topics but didn’t find anything that seemed to suggest a course of action on this.

I’d attach the Discourse Doctor output expect new users can’t upload documents and I can’t quote it because new users can only post 2 links. So the link to the server location is here: http://forums.nyheritage.org/NjliZDRlYzE3NTZlZTU0.txt Hopefully that works.

Any suggestions on further things to try would be appreciated! Thanks!


502 Bad Gateway for me too. Yikes.

1 Like

Same issue here, 502 after running docker update

1 Like

Seems to be the case for me as well. Fighting all morning trying to get a fix.

Whats strange is if you stop the container you can get to the site, its just extremely slow. (cloudflare cache)
Another helpful error:

`bind': Cannot assign requested address - bind(2) for [::1]:3000 (Errno::EADDRNOTAVAIL)
/var/discourse# docker ps --all
CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS                     PORTS               NAMES
ae2dac939415        local_discourse/app   "/sbin/boot"        7 minutes ago       Exited (5) 2 minutes ago                       app
1 Like

I’m looking into it.


Similar problem here: I’ve rebuild the app (./launcher rebuild app) and now the site is returning this error. I was trying to add a new container and setup a multi forum with nginx proxy but something goes wrong, when I’ve reverted the changes to the original ones the forum stopped working (… yes, I’m sure the settings have been correctly restored). :frowning:

1 Like

Same issue as well, ran the Docker update and then tried to apply the discourse updates only to get the 502 error. The upgrade implied it failed and I was seeing a 500 error, I went ahead and did a rebuild (./launcher rebuild app) and now I’m seeing the 502.

1 Like

We’ve identified the problem and are building a fix.


Thank you, will you notify the update when it will be ready? :slight_smile:

Of course, we’ll post in this topic when the fix is ready.


Same issue here. So how do we implement the fix without the web update button running?

Could an interim fix be to revert to a previous version of discourse_docker then rebuild?

You will have to ssh into the machine and do a

./launcher rebuild app


A fix is now available. If your server is currently returning 502 errors, you will need to connect via ssh and run

cd /var/discourse
./launcher rebuild app

For anyone who hasn’t updated yet, it is now safe to hit update in docker manager


Thank you, now the forum is working as expected :slight_smile: Good job!


Fix worked for me as well. Thanks for the quick response!


Fixed! Nice work :heart_eyes:


Fixed! Nicely done! Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.