Admin Plugin page is blank - Error: There is no route named adminPlugins.index


(Magnetidog) #1

Hello!

I just upgraded via shell on a DigitalOcean installation with any size Discourse forum. All is working fine, with the exception of the plugin area in the Administration panel, which is entirely blank.

If I go to admin/upgrade, the list loads fine, instead.

I see this error in Firebug coming from a js file:

Error: There is no route named adminPlugins.index
http://mydomainhere/assets/ember_jquery-37ec8949e7219a8c2b3cdebef9d43bc64a66860ec196f3e10bea842d0296256f.js
Line 16

Tried to search in the forums for the same issue but I could not find anything.

I attempted multiple rebuilds and disabled plugins, without luck.

Thanks!


(Jeff Atwood) #2

Try entering safe mode: How to use Discourse Safe Mode


(Alex S) #3

Im seeing this as well.

Version: 1.7.0.beta8


(Sam Saffron) #4

Is it working fine in safe mode. Did you upgrade to latest?


(Alex S) #5

It’s not working in safe mode, and looks it upgraded to latest automatically.


(Sam Saffron) #6

Can you try

cd /var/discourse
git pull
./launcher rebuild app

If it is still broken this may be related to some routing change @eviltrout made yesterday, what locale is your forum?


(Alex S) #7

Rebuilt the app, still broken.

I tried both English and Chinese.


(Vinoth Kannan) #8

PR added


(RĂ©gis Hanol) #9

Isn’t the “index” route supposed to be automatically added by Ember?

Also, that route works fine here on meta. We still don’t have a clear reproduction case.


#10

Hi, I installed discourse on localhost a few hours ago, and I have almost the same error, but to me it doesn’t show any error, just blank page. I use firefox esr, it allows javascript, I run git pull and rebuilt it again to get the fix vinothkannans, but no luck…


(Vinoth Kannan) #11

It returned the error in development environment. That’s why I created that PR. Surprisingly it is working fine for me too in production server.

My PR not yet merged with master.


(RĂ©gis Hanol) #12

I can confirm that this route doesn’t work in dev anymore.

I merged @vinothkannans’s PR but I will leave it out to @eviltrout to ensure this is the right fix (not sure why this is the only route we have to do that…)


(Magnetidog) #13

Hello,

indeed, using safe mode did not make a difference. I tried multiple times with the whole rebuild process. The weird thing is that this occurs in some installs and not in others, even with the exact same plugins.

I have not tried the fix by @vinothkannans yet!


(Vinoth Kannan) #14

I found way to reproduce in production server. If we use a plugin which use a nested route of adminPlugins then we will not have the issue. In this case index route created automatically like @zogstrip mentioned . For example I am using discourse-navigation plugin which have page as /admin/plugins/navigation. So I am not having the issue in my live. Like it I guess meta.discourse will have akismet plugin.

If we don’t have any plugins which using that path then we can see the issue.


(Alan Tan) #15

Meta is still on the Ember 2.4 branch which is why it isn’t breaking here.

It looks like in the newer versions of Ember, you need to have a nested route in order for Ember to generate the index route automatically


(Miguel) #16

Hi!

I have the same error, forum is blank.

I try reboot and rebuild, but not work.

If I enter in safe-mode works fine. Any solution??


(Vinoth Kannan) #17

When you done rebuild? Recently a PR for this issue is merged with master. You may need to try again.

How it created the index route automatically when all plugins disabled :open_mouth:


(Miguel) #18

Okey, I upgrade with the new two commits: forum is blank.
I reboot and rebuild: forum is blank :frowning:

I clarify that the entire forum is left blank, not just the plugins page.


#19

It worked for me :stuck_out_tongue: Thank you very much @vinothkannans! :smiley:


(Miguel) #20

What exactly have you done? Step by step please :smile: