Admin Plugin page is blank - Error: There is no route named adminPlugins.index

Can you try

cd /var/discourse
git pull
./launcher rebuild app

If it is still broken this may be related to some routing change @eviltrout made yesterday, what locale is your forum?

Rebuilt the app, still broken.

I tried both English and Chinese.

PR added


Isn’t the “index” route supposed to be automatically added by Ember?

Also, that route works fine here on meta. We still don’t have a clear reproduction case.

Hi, I installed discourse on localhost a few hours ago, and I have almost the same error, but to me it doesn’t show any error, just blank page. I use firefox esr, it allows javascript, I run git pull and rebuilt it again to get the fix vinothkannans, but no luck…

1 Like

It returned the error in development environment. That’s why I created that PR. Surprisingly it is working fine for me too in production server.

My PR not yet merged with master.

1 Like

I can confirm that this route doesn’t work in dev anymore.

I merged @vinothkannans’s PR but I will leave it out to @eviltrout to ensure this is the right fix (not sure why this is the only route we have to do that…)


indeed, using safe mode did not make a difference. I tried multiple times with the whole rebuild process. The weird thing is that this occurs in some installs and not in others, even with the exact same plugins.

I have not tried the fix by @vinothkannans yet!

I found way to reproduce in production server. If we use a plugin which use a nested route of adminPlugins then we will not have the issue. In this case index route created automatically like @zogstrip mentioned . For example I am using discourse-navigation plugin which have page as /admin/plugins/navigation. So I am not having the issue in my live. Like it I guess meta.discourse will have akismet plugin.

If we don’t have any plugins which using that path then we can see the issue.


Meta is still on the Ember 2.4 branch which is why it isn’t breaking here.

It looks like in the newer versions of Ember, you need to have a nested route in order for Ember to generate the index route automatically



I have the same error, forum is blank.

I try reboot and rebuild, but not work.

If I enter in safe-mode works fine. Any solution??

When you done rebuild? Recently a PR for this issue is merged with master. You may need to try again.

How it created the index route automatically when all plugins disabled :open_mouth:

Okey, I upgrade with the new two commits: forum is blank.
I reboot and rebuild: forum is blank :frowning:

I clarify that the entire forum is left blank, not just the plugins page.

It worked for me :stuck_out_tongue: Thank you very much @vinothkannans! :smiley:

1 Like

What exactly have you done? Step by step please :smile:

Fixed! The problem after updating to the latest version was the babble plugin. I’ve disabled it and everything works fine.


This is a correct fix, so thanks to @vinothkannans and @zogstrip for merging it so quickly.

I was surprised by this behaviour too. Previously there was the concept of a route and a resource, but the resource was removed in favor of the { resetNamespace: true } option which makes a lot more sense. However, not every route is considered a new “level”. For example:

this.route('hello', function() {

In this case, ‘hello’ gets an index, but ‘world’ does not. This makes sense to me, because ‘world’ would probably just be something related to ‘hello’. So the way Ember decides if it should add an index is by whether a route is a new “level” of routes, which is determined by whether it is created with a function as the final argument:

this.route('hello', function() {
  this.route('world', function() {
    // now a new level, gets an index

So @vinothkannans’s fix was to add a new function. He explicitly defines index to make it clear what we want, but just having the new level there would have done it anyway.


The fix worked for me, as well! Thanks @vinothkannans !

1 Like

Thank you @vinothkannans it works for me too now.

1 Like