Advanced Developer Install - rake db:create db:migrate bug

Dear all,

i hope somebody is able to help me with the bug what i have at my install try as follows:

Debian 10
php 7.3.6

i use this guide:

But always at the db migration i get the following error - i have also tried diff. releases, always same problem:

/var/www/discourse# RAILS_ENV=production bundle exec rake db:migrate
rake aborted!NoMethodError: undefined method `keys' for nil:NilClass/var/www/discourse/app/models/global_setting.rb:57:in `load_defaults'/var/www/discourse/config/application.rb:32:in `<top (required)>'/var/www/discourse/Rakefile:5:in `require'/var/www/discourse/Rakefile:5:in `<top (required)>'/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/rake-12.3.2/exe/rake:27:in `<top (required)>'/var/www/discourse/vendor/bundle/ruby/2.6.0/bin/ruby_executable_hooks:24:in `eval'/var/www/discourse/vendor/bundle/ruby/2.6.0/bin/ruby_executable_hooks:24:in `<main>'

I had also searched for different guides or anything else at the web - but nothing found how to get this error fixed or how i could continue with the install.

I have also tried the docker install way - which was working at the setup - BUT it is not compatible with my used ISPConfig - discourse at subdomain get partial broken & after admin account registration, the wizard does not continue & always blank page anymore

Thanks in advance & kind regards,


That guide is meant for setting up development environments…and not production servers. For servers, we only officially support our Docker guides:

I don’t think it is reliable or even possible to install Discourse on a prod server using a guide meant for development purposes.

Maybe you could try to work around the ISP problem or try hosting Discourse with an external provider?


Thanks for fast reply

About the “guide” was just to give an idea - as mentioned i have tried with the docker - but no chance to get it working correctly.
I have set up the reverse proxy and everything.

Setup was ok without issue
BUT, Discourse get broken in style as well after admin registration only blank page & the wizard don’t start or continue - i have checked in database as well in the ruby app - admin account is/was active.

IspConfig tells me this is not related to their panel, it is an issue with Discourse - as well docker is not supported by IspConfig

I think the issue is regarding nginx vhost settings - but i don’t know which part i need to insert into the IspConfig control panel (similar as it is with other for example plesk - i have also read the postings here and tried different things)

Therefore i tried to install it without docker, what is possible for example by this guide:

There will be nothing special done as it is similar done by the default setup via docker

The assistance what i need is - what is the error what happens at db miration as mentioned above?

I cannot find anything in the web about it - and i would like to use discourse for my wordpress website what would be the perfect integration for comments & further support

If you have an idea how to get discourse working by docker & IspConfig - also perfect - it is my own server i can use in every way

The only issue in total is - i MUST install IspConfig before Discourse - because IspConfig needs the clean server for 100% clean working - first discourse with docker and then try to get IspConfig and the rest inside - not possible

Thanks in advance

See Running other websites on the same machine as Discourse

It will be difficult and perhaps impossible to get it to work with ispconfig. If you want to run discourse with ispconfig you should ask ispconfig for help.


i have tried this from the posting " Running other websites on the same machine as Discourse" to get it working with the docker - but after x hours, no success

my last idea is now without the docker, because docker not supported by ispconfig - but i need here assistance reg. the error message:

/var/www/discourse# RAILS_ENV=production bundle exec rake db:migrate

rake aborted!NoMethodError: undefined method `keys’ for nil:NilClass

/var/www/discourse/app/models/global_setting.rb:57:in load_defaults'/var/www/discourse/config/application.rb:32:in <top (required)>’/var/www/discourse/Rakefile:5:in require'/var/www/discourse/Rakefile:5:in <top (required)>’/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/rake-12.3.2/exe/rake:27:in <top (required)>'/var/www/discourse/vendor/bundle/ruby/2.6.0/bin/ruby_executable_hooks:24:in eval’/var/www/discourse/vendor/bundle/ruby/2.6.0/bin/ruby_executable_hooks:24:in `’

I have tried the 2.4. beta, which will be also installed with docker and different other releases from github

Thanks in advance

Ispconfig is not supported by the Discourse community.

No good can come from running a development installation for a production site. For $5/month you can just get a digital ocean droplet (or similar) and it will work.