After a clean install : Sidekiq error


(@SenpaiMass) #1

I am using a linode 1gb ram setup

The installation/upgrade process goes clean but i get this error in mysite.com/admin (dashboard)


(Alan Tan) #2

Can you post the full logs from ./launcher start yourapp? Need more information to figure out what is going on :wink:


(@SenpaiMass) #3

i did ./launcher logs app
and got this

run-parts: executing /etc/runit/1.d/00-ensure-links
run-parts: executing /etc/runit/1.d/anacron
run-parts: executing /etc/runit/1.d/cleanup-pids
Cleaning stale PID files
run-parts: executing /etc/runit/1.d/copy-env
run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
Started runsvdir, PID is 29
sh: echo: I/O error
ok: run: redis: (pid 43) 0s
ok: run: postgres: (pid 42) 0s
rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003 ]
rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
43:M 07 Dec 11:56:08.479 * Redis 3.0.5 (00000000/0) 64 bit, standalone mode, port 6379, pid 43 ready to start.
43:M 07 Dec 11:56:08.483 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
43:M 07 Dec 11:56:08.484 # Server started, Redis version 3.0.5
43:M 07 Dec 11:56:08.484 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
Server listening on 0.0.0.0 port 22.
Server listening on :: port 22.
rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039 ]
2015-12-07 11:56:08 UTC [58-1] LOG:  database system was shut down at 2015-12-07 11:54:41 UTC
2015-12-07 11:56:08 UTC [58-2] LOG:  MultiXact member wraparound protections are now enabled
2015-12-07 11:56:08 UTC [42-1] LOG:  database system is ready to accept connections
2015-12-07 11:56:08 UTC [62-1] LOG:  autovacuum launcher started
43:M 07 Dec 11:56:08.664 * DB loaded from disk: 0.179 seconds
43:M 07 Dec 11:56:08.664 * The server is now ready to accept connections on port 6379
supervisor pid: 40 unicorn pid: 64
43:M 07 Dec 12:01:09.029 * 10 changes in 300 seconds. Saving...
43:M 07 Dec 12:01:09.029 * Background saving started by pid 8288
8288:C 07 Dec 12:01:09.176 * DB saved on disk
8288:C 07 Dec 12:01:09.177 * RDB: 1 MB of memory used by copy-on-write
43:M 07 Dec 12:01:09.230 * Background saving terminated with success
43:M 07 Dec 12:06:10.055 * 10 changes in 300 seconds. Saving...
43:M 07 Dec 12:06:10.056 * Background saving started by pid 15521
15521:C 07 Dec 12:06:10.262 * DB saved on disk
15521:C 07 Dec 12:06:10.262 * RDB: 1 MB of memory used by copy-on-write
43:M 07 Dec 12:06:10.357 * Background saving terminated with success
Shutting Down
run-parts: executing /etc/runit/3.d/01-nginx
ok: down: nginx: 0s, normally up
run-parts: executing /etc/runit/3.d/02-unicorn
exiting
ok: down: unicorn: 0s, normally up
run-parts: executing /etc/runit/3.d/10-redis
43:signal-handler (1449490107) Received SIGTERM scheduling shutdown...
43:M 07 Dec 12:08:27.075 # User requested shutdown...
43:M 07 Dec 12:08:27.081 * Saving the final RDB snapshot before exiting.
43:M 07 Dec 12:08:27.522 * DB saved on disk
43:M 07 Dec 12:08:27.524 # Redis is now ready to exit, bye bye...
ok: down: redis: 0s, normally up
run-parts: executing /etc/runit/3.d/99-postgres
2015-12-07 12:08:27 UTC [42-2] LOG:  received smart shutdown request
2015-12-07 12:08:27 UTC [62-2] LOG:  autovacuum launcher shutting down
2015-12-07 12:08:27 UTC [59-1] LOG:  shutting down
2015-12-07 12:08:27 UTC [59-2] LOG:  database system is shut down
ok: down: postgres: 1s, normally up
run-parts: executing /etc/runit/3.d/99-ssh
Received signal 15; terminating.
ok: down: sshd: 0s, normally up
run-parts: executing /etc/runit/1.d/00-ensure-links
run-parts: executing /etc/runit/1.d/anacron
run-parts: executing /etc/runit/1.d/cleanup-pids
Cleaning stale PID files
run-parts: executing /etc/runit/1.d/copy-env
run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
Started runsvdir, PID is 21
sh: echo: I/O error
ok: run: redis: (pid 38) 0s
ok: run: postgres: (pid 35) 0s
rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003 ]
rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
38:M 07 Dec 12:08:45.187 * Redis 3.0.5 (00000000/0) 64 bit, standalone mode, port 6379, pid 38 ready to start.
rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039 ]
38:M 07 Dec 12:08:45.189 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
38:M 07 Dec 12:08:45.190 # Server started, Redis version 3.0.5
38:M 07 Dec 12:08:45.190 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
Server listening on 0.0.0.0 port 22.
Server listening on :: port 22.
2015-12-07 12:08:45 UTC [50-1] LOG:  database system was shut down at 2015-12-07 12:08:27 UTC
2015-12-07 12:08:45 UTC [50-2] LOG:  MultiXact member wraparound protections are now enabled
2015-12-07 12:08:45 UTC [35-1] LOG:  database system is ready to accept connections
2015-12-07 12:08:45 UTC [54-1] LOG:  autovacuum launcher started
38:M 07 Dec 12:08:45.396 * DB loaded from disk: 0.206 seconds
38:M 07 Dec 12:08:45.401 * The server is now ready to accept connections on port 6379
supervisor pid: 32 unicorn pid: 56

(@SenpaiMass) #4

I am getting this with the latest update! on a Digital ocean 2GB cloud as well.
Updated discourse via ./launcher rebuild app


(@SenpaiMass) #5

Here is my latest update version


(cpradio) #6

What plugins do you have installed?


(@SenpaiMass) #7

@cpradio

This is the new one after i removed every plugin except discourse tagging, still getting the same issue with sidekiq


(cpradio) #8

Okay, that makes me feel better. I couldn’t see anything with the plugins you listed that would denote any issues, but I wasn’t sure.


(@SenpaiMass) #9

I guess this is a new update bug?


(cpradio) #10

Maybe, as it works on +94. Give me 30 minutes to upgrade and we’ll find out!


(cpradio) #11

Seems okay to me

Visiting /sidekiq works too.

My instances has literally zero activity though.


(Bogdan) #12

I also get this after upgrading a few minutes ago:

Visiting /sidekiq works


(Sam) #13

I’m getting this on my server as well (on commit fa66878 from this morning). /sidekiq is still there, but jobs are queueing up without being completed.

@codinghorror, @eviltrout (sorry not sure who on the team handles this sort of thing), just want to make sure you guys know this isn’t just a new installation issue. If the categories page is any indication, it’s happening here on Meta as well.


(Rafael dos Santos Silva) #14

So thats why latest page on meta doesn’t update participants pictures!


(@SenpaiMass) #15

Did any one get a fix for this?


(Robin Ward) #16

I’m looking into it right now.


(Robin Ward) #17

Okay looks like a recent commit broke a forked version of sidekiq.

I’ve reverted the commit and it’s working again now on tests-passed. The commit will be fixed before being un-reverted.


(Sam Saffron) #18

My bad… I renamed a bunch of files and forgot one spot:

Apologies


(Sam Saffron) #19