After upgrade the site doesn't load


(Pad Pors) #1

Hi, I just upgraded our site to latest, and when I try to open it in firefox, it gives me this error:

The site at https://padpors.com/ has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

I couldn’t also open the site in chrome. though the site seems to be up.

I would be thankful for any help or hints showing me what to do. as I couldn’t find any proper solution in the web so far.


(Bhanu Sharma) #2

Network violation error seems to be a side effect of the recent changes done in favour of eliminating the “Cannot load app” problem. I too get it when I wake up my work laptop from sleep and then a refresh is what it takes to fix.

This happens to me only on firefox.

Your site is loading fine here. Screenshot below.


(Daniela) #3

The site is up for me. Since yesterday I saw your same error on many Discourse sites using Firefox 59.x.
It’s still this error “Cannot Load App”.... in Firefox sometimes. Refresh fixes it

It should be fixed when Firefox version 60 is released during the first week of May.
If you click on the Try Again button your site should load normally


(Bhanu Sharma) #4

@dax I remember some changes were pushed in discourse core to better handle the issue! Maybe that is causing this?


(Daniela) #5

I don’t think, from what I know the only commit is this one for user offline

@Falco can confirm it or not.


(Pad Pors) #6

many thanks for your responses, I still can’t open the site using either firefox or chrome. may it be due to slow web connection? or may you let me know what browser you use?

p.s. I agree that the site is up, as we haven’t got the down-message from up-time robot.


(Bhanu Sharma) #7

I’ve tried on Chrome mobile, Firefox on Laptop. it loads fine on both


(Daniela) #8

The site opens on all these browsers:

Chrome Version 66.0.3359.139 (Official Build) (64-bit)
Firefox 59.0.3 (64 bit)
Edge 41
IE 11