Blank page with Firefox, need to refresh the page

Hi everyone.

I updated our old forum to the latest version successfully. But since, i’ve got an issue with FireFox 94.0.2.
Discourse 2.8.0.beta8.
When I try to go to our forum, I’ve got a blank page. If I refresh this one through CTRL F5, that works.
Once login, the page is blank again and I need to refresh through CTRL F5 again.
I tested with Chrome and Microsoft Edge. No problem.
Also I tested on an other workstation, same issue.
Of course, I cleaned the browser cache too. No way.

Can you help me please?

Franck

Hello, what is the URL of your forum?
I searched in your profile but it wasn’t there, either.

@jesus2099

1 Like

Hey that’s interesting.
I’m using Android 9’s Firefox for Android 68.11.0.

As soon as you posted your link, I went there, no issues.
Now I go back there and I do have your blank page, plain white page.
So it’s because of something that remains in our browser context (cookie, local storage, cache, something) after first visit.
If I open it in a private window it’s ok, because it simulates a virgin environment, each time.

You have a CSP violation on that site.

Looks like your CDN is responding with 301 instead of serving assets:

curl -I https://fpbxforums-sangomaus.netdna-ssl.com/assets/plugins/discourse-canned-replies-33e4732aee5d0bec3cee72adc45b9a5f41c8eaf95bdddb5b4d3026ec6280af09.js
HTTP/2 301 

You need to either fix or disable the CDN.

5 Likes

Thanks for your reply
It doesn’t explain that happens on other work station which never been on this forum.
I will try to see if I can clean up the cache more efficiently.

1 Like

How explain that works for the other browsers like Chrome and Edge?
301 is redirecting info.

1 Like

I cleaned everything in cache, same issue.

1 Like

Private navigation (try that! It’s usually Ctrl+Shift+N) is much more than just cache, it’s totally virgin of local storage, cache, cookies, and maybe something else. :wink:

But @Falco advice seems good.
I don’t know what is a CDN, but if you have CSP issue, it could mean you should host your JavaScript on the same server as the page, and the link to it should be same server.

But here it is fpbxforums-sangomaus.netdna-ssl.com instead of community.freepbx.com.
Even if in the end it redirects to same server, maybe Firefox is more cautious about security than other browsers on this aspect. The other browsers may catch up on that, later.

But I’m just elaborating on Falco’s hint.
I’m not really sure myself. :sweat_smile:

With a private navigation that works indeed (CRTL SHIFT P) . But I tried on other workstations out off home which has never been on this forum and get this issue.So, it’s not the fact to keep any previous data (cookies…Etc)

And I don’t explain we’ve got this issue after update. That worked correctly before.

1 Like

It’s not clear why it’s working at all.

If you want your site to work you’ll need to either fix or remove your cdn.

1 Like

ok thanks
I will see with our IT team what it’s possible to do with CDN.

I will let you know.

2 Likes

I changed the CDN value on app.yml file.
How to apply it after change?
I launched: ./launcher restart app but the issue is still present
It’s the good way to do that or I need to launch: ./launcher rebuild app

You will need to rebuild the app to apply those app.yml changes. :+1:

After rebuild, Should I restart it as well?

I normally just rebuild, and my site is up and working again as soon as it’s finished.

1 Like

Hi everyone.

Thansk so much for your help. That works fine right now.
The URL was not the good one, the IT gave a new one and after apply the changes, all is working fine with Firefox.

Have a nice day everyone.