"Allow messages" setting not found

A user is complaining about not receiving direct messages through chat, also the sender sees a “user has deactivated chat” error. In trying to guide them to re-enable messages, I told them to go to Preferences > Users, where I see a section called “Messages” including the setting “Allow other users to send me personal messages and chat direct messages”. However, this user doesn’t have the setting (I checked by impersonating them).

  1. Why is that?
  2. Where else may they have deactivated messages?

Is the user member of a group that is allowed to use chat and direct messages? I’d check the chat allowed groups and direct message enabled groups site settings.

Seems the discription of direct message enabled groups is a little misleading

Allow users within these groups to create user-to-user Personal Chats. Note: staff can always create Personal Chats, and users will be able to reply to Personal Chats initiated by users who have permission to create them.

I’m not able to start a DM with a user who is not allowed to use chat; they can only reply to chats that were created when they were allowed to use chat.


Thank you, @Moin, very helpful!

That’s a more complete test, but in case you didn’t know, admins (and maybe moderators?) can change user preferences without impersonating (which saves the annoying logout/login cycle). (If you did know, maybe this will help someonoe else)

1 Like