Android app installation is not offered


I tried to install the Android app (shows as chromium webapk on the system) for three forums. This one here (worked), a self hosted forum (worked) and another self hosting forum (did not work).

For the last forum a link somehow showed up and installed not the app but more than a bookmark or something like this - but shows a nice startup screen.

But as I do not see the app in the app list in the Android settings and also not in Titanium Backup. I also cannot select or unselect the app when it comes to notifications for a smart watch for example. So it is something else.

So, my hopefully simple question is, how can I get the installation done and also how can I (re)start it by hand, as I also want to notifiy our users about that. Opening up https://domain.tld/?discourse_app=1 in a browser on the Android device does not do anything at all. Also deleted all browser data like cache, cookies… I also do not know what the difference here is, especially between the two self hosted forums, as I setup these two very identical.

Thanks and regards,


Please share the URL of the one that is failing.

1 Like

Sure :slight_smile:

Any idea why I cannot install the app with this forum?

Also is there any manual method?

1 Like

They have to have defined a large logo in their site settings, and enabled the option for the native app install banner. Both steps are required.

1 Like

You mean the large icon? It is set, with a lot of other images as well. Also native app install banner android is checked. Both of my own forums are set up quite identical, for one it works on Android, for the other not.

Btw, I did not see any install message on iPad or iPhone for any of the forums, including this forum ( native app install banner ios is checked on my own forums as well.

That’s because your logo is a JPEG instead of a PNG.

Please upload a 512x512 PNG to the site setting manifest icon in the admin > settings > branding page.

A small correction here: You should not enable native app install banner if you want your users to install your webapk / pwa, as that will substitute it for the DiscourseHub.


Oof, thanks, good catch. More caffeine required :man_facepalming:t2:


Thank you @Falco and @Stephen - it worked! :slight_smile: At least for Android. :slight_smile:

How / where do I see an install button or function under iOS? I checked Safari and Chrome and also the menus but did not see anything there.

Btw, would it be a good idea to put an information into the description for the manifest logo that it should / has to be an PNG?

It’s there on the setting:


We had a warning for that for site admins, but people complained about having a warning, so :person_shrugging:

Apple declined to implement this on iOS, so there is no event nor native UI for it.

1 Like

I can’t read anything about “use PNG, JPG is bad here”. :wink: Also not in the German translation.

OMG… People…

I see. Apple… So then I check the native app install banner ios setting to at least notify the people about the Discourse Hub app. What would you suggest?

1 Like

AFAIK the only image which mentions needing to be a PNG is the favicon.

1 Like

Well, if the Android app installation only works with a PNG image as manifest logo a note there really would be useful. :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.