As an admin, I'm unable to see the full list of grantable badges

Greetings! I’m the new admin of a community here on Discourse and I’d love to grant badges to specific users. We have about 20 badges that I can see on the list in the admin panel but, when I select a user and try to give them one of our custom badges, I’m only able to see a handful.

I’m quite new to Discourse so my apologies if I’m missing something obvious!

Thanks a million,

1 Like

It only shows the list of “grantable badges”, i.e.:

  1. the badge is enabled,
  2. the badge is not an automatically granted badge (system badge, SQL query badge)
  3. the badge has not been granted to the user before, unless it can be granted multiple times

Thanks so much for helping me out here, it means a lot.

As far as I can tell, I’ve changed the settings to match your suggestions but, sadly, cannot grant the badge. These are the settings for the specific Badge I’m trying to grant.

The Badge is enabled, I’ve never granted it before to this particular user before and it is not an auto-generated badge. FWIW, I also changed the settings to allow the badge to be given multiple times, but that also did not allow me to see the Badge in the “grantable badge” dropdown menu.

Any ideas?

Thanks again for helping my Discourse-n00b self! :flushed:

:thinking: That’s weird, I just tried out your settings and it worked for me:

Badge settings (really tall screenshot)

Grantable badges list

Could you try creating a new badge with the settings you have? Or maybe trying granting it to a different user?

1 Like

Ok, did both.

  • When I created a new badge with the same settings I WAS able to see it as a grantable badge in the drop-down menu.

  • WhenI tried to apply the existing, problematic badge to someone else I still was not able to grant it or see it on the menu.

:thinking:, indeed.

If it gives more context this Badge is a gold level badge.

Can you double check that the user doesn’t already have this particular badge? As “can be granted multiple times” is off. Maybe one of your other admins already did it!


Yup, I’m sure the user does not have the Badge I’m trying to grant. I just double-checked to be sure.

If that’s the case, I’d just delete the problematic one and use the newly created one.

One possible edge case that I can think of: the badge has a SQL query, but the functionality is disabled and thus the query is hidden.

All in all, I’d recommend using the new badge.


Hmm, so this Badge has been given out to others in the past… will deleting the Badge remove it from those who already have it?

The new Badge I made was just a test, I didn’t recreate the Badge that’s causing issues.


I wanted to bump this thread because I am still seeing the same issue. There are a 20-30 of badges that we have as options, but only 5 are ‘grantable’ when I try to give them to a specific user.

I’m really at a loss here, so I’d welcome any help.