Auto-response when taking action on flags


#1

Hi there – I searched all over my admin settings and meta.discourse but couldn’t seem to find the answer. Apologies if this topic has already been addressed.

Is there a way to disable an auto-response to the flagger when you take action (agree, disagree or defer) on a flagged post?
For example, I deferred a flag that was created by our system for flag_sockpuppets and it auto-replied with "Thanks for letting us know. We’re looking into it."
I would upload a screenshot of it but I’m still a new user.

I’d like to know if there is a way to disable this because this response gets sent out to all of the admins which isn’t necessary and it’s certainly not necessary to send our “system” a response.

thanks!


(Lisa Wess) #2

Agreed; we discovered this a few days ago and I’d like to stop it.


(Kane York) #3

This feels like a bug, I don’t think that auto-message should be generating notifications


(Jeff Atwood) #4

And especially not to system user cc @zogstrip


(Régis Hanol) #5

That’s now fixed :bug:


(Régis Hanol) #6

Just added the “auto_respond_to_flag_actions” site setting :panda_face: (cc @lisajill)

https://github.com/discourse/discourse/commit/afd24179456c45e4c4594c2bc3ae29063e18ec70


(Régis Hanol) #7

(Jeff Atwood) #8

@zogstrip I wish I could have caught you before you did that … there is already a way to avoid auto responses to flags, make sure a staff member replies to the flag before handling it. The auto replies only happen if there is not currently a staff reply on the flag PM.

So just reply to the flag PM, then handle the flag.


(Régis Hanol) #9

FYI: I pushed a fix changing that test to a moderator instead of the moderator.

https://github.com/discourse/discourse/commit/df7c38dd51f3754d90d8829eb65091e4ddb415b2


(Jeff Atwood) #10

Oh, my bad, that was an error in the implementation due to me not communicating it clearly…