Automatic AI image caption setting not saved

Hello :wave:

I’ve tried to set up the automatic AI image caption and it seems the settings not saved. When I click the Enable button on modal it seems works until I reload the page. Then when I go to the setting to enable it the setting seems not save.

The difference between Meta and my site is the checkbox. If I turn on / off here it keeps checked / unchecked after I save it. On my site it’s always unchecked.

It doesn’t matter I turn on this setting the uploaded image won’t automatically captioned. :thinking:

I didn’t notice any error in console or logs.

Thanks :slightly_smiling_face:

3 Likes

Hello :wave: Is anybody experienced it? If so than we can move it to bug :thinking:

Setting is saved without problems. But captions are never created. So something funny is happening there.

:thinking: hmmm that’s odd can you please check your /u/don.json on your site and see if you have user.user_option.auto_image_caption property?

Setting is working for me, and the captions are creating. There is some criteria for auto captions:

  • it contains images
  • images are not small (> 0.4 MP)
  • their current alt text is bad (single word, less than 20 chars)

Is it still not creating captions even with images under this criteria?

3 Likes

I can’t count using marketing metrics such MP is, but those are 1024xsomething by pixelsize.

This didn’t get a caption

Does Discourse use filename instead if there is not an alt text? Those are always under 20 chars :thinking:

I think this should split in two. We are off topic now.

1 Like

Thanks @keegan! I’ve checked it.
Here, I can see "auto_image_caption": true so maybe the criteria not meet :thinking:
but

The images, I tried to upload is mobile made photos. These are more then 0.4MP, I think. :thinking: Unfortunately now I can’t check it. My phone is broken…

I tried to upload images with same format of alt text. For example: IMG_20240610_xxxx. Sometimes generates the alt text when it’s uploaded, sometimes not.

I think it would be better to generate every uploaded image…


On my site I checked the /u/username.json too but I didn’t find the “auto_image_caption”. :thinking: I think it’s because I can’t save it on my settings the checkbox is always unchecked. Maybe a conflict with other plugin :thinking: But if it’s unchecked should I see "auto_image_caption": false?

My site setting is:
ai helper enabled features: image_caption
ai auto image caption allowed groups: trust_level_4
ai helper image caption model: Google - gemini-1.5-flash


Finally, I can turn on my phone. Testing time :slightly_smiling_face:

No alt text generated


3648x2736px 2.93MB


3648x2736px 4.17MB

Maybe the automatic image optimization compress it too small to start the alt image captioning. :thinking:

Let’s try bigger images.


5472x7296px 10.56MB


5472x7296px 9.91MB

Unfortunately it didn’t generate Alt text :confused:

2 Likes

It should still appear even if you can’t save it in your settings. The field should appear and show false

There are a few things necessary for it to be setup.

  • Do you have discourse-ai installed and enabled?
  • SiteSetting.composer_ai_helper enabled?
  • SiteSetting.ai_helper_enabled_features includes image_caption
  • Is the user you are testing with on your site a member of the groups set under SiteSetting.ai_auto_image_caption_allowed_groups ?

Could you confirm you have these setup? :point_up:

4 Likes

Thanks, this was it. :slightly_smiling_face: I’ve enabled this site setting and now the auto image caption setting saved correctly.

2 Likes

Yes. all are done.

But every time I insert the image I’ve to click Caption with AI in the composer window’s preview area.

Is there a way that all images are ‘Automatically Captioned with AI’, without the need of clicking on “Caption with Ai”?