Automatic backup not working

I’ve followed this guide, and this, but my automatic backups fail. When I check in AWS, the public access settings for my bucket is set to “Block all public access”. When I try to allow the necessary public access, the systems says 100% success and the setting is still the same :joy:

How do I make the correct settings stick?

Edit: I learned that several settings affect the bucket public access settings. I tried various settings for “Block public access (account settings)” and I checked permissions for Access control lists, Bucket policies and Access point policies, none of which I have.

Here is where I try to allow the public access, is it the right place?


1 Like

What’s the error?

I’d be careful with that. You don’t want to make your backups public by accident!


There is no error message. The backup just doesn’t happen when it should.

I am worried about the public access, for sure! At the moment though, I would just like to see a backup successfully stored on S3. I may eventually just abandon the whole automatic backup thing, if I’m not convinced the data will be safe on S3 with the public access that is required for it to work.

1 Like

As an admin you should get a PM whenever an automatic backup fails. It contains the log output of the backup process.

I have a couple of questions:

  • Is this a standard Docker based install?
  • Do manual backups work?
  • Is there a warning about a paused Sidekiq in the admin dashboard?
  • Are your uploads stored on S3 as well or just backups? Are you using different buckets for uploaded files and backups?

Where did you get the idea that it is required? It is not! We might need to clarify our documentation if you read it there.


I got no PM’s about failed backups.
It’s a standard Docker based install.
Manual backups work.
No warning of a paused Sidekiq.
I don’t store uploads on S3.

About the public access requirement, see this thread, in the “Bucket” section:
Setting up file and image uploads to S3


That’s strange. Did you change any of the backup related settings (see /admin/site_settings/category/backups) besides backup_location?


I did, but to test if any settings were wrong, I reset all of them, except:

backup location: S3
backup frequency: 1
S3 backup bucket: “my bucket”
backup time of day: I set this to a few minutes ahead, to start the backup.

Still nothing happens. I haven’t yet waited a full day for the daily backup to start but I checked that the server is running with the correct time.

1 Like

Please note that backup time of day is in UTC and not a local time. And backup jobs are only scheduled once per day at midnight, so it won’t start right away. You have to wait a day for it to happen!


Sure, I’ve been setting the backup time to current UTC + 2 minutes. But why have the “backup time of day” setting if it only happens at midnight? In any case, it’s past UTC midnight now, and again nothing happened. So it seems not a time issue.

1 Like

Hey @lyseoy

Just to be comprehensive, you might also check the Job Scheduler: 

Then look for the “ScheduleBackup” entry:

If you find the entry, you might want to trigger the job and see if you can trigger it directly from the scheduler.

Hope this provides a new clue or confirms what you already know.


The “ScheduleBackup” job runs at midnight and schedules a backup at backup time of day if automatic backups are enabled and the last backup file (automatic or manual) is older than backup frequency days.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.