Avatars blocked due to Privacy Badger extension

menu

(Theis Holtz Hansen) #1

Hi

I just updated to the newest version (v1.4.0.beta12 +55) and the profile menu disappeared. As well as the list of users participating in a topic.


(Jeff Atwood) #2

What exactly are you referring to? Everything is here, there is nothing missing.


(Theis Holtz Hansen) #3

the little profile menu besides the hamburger menu and search. This is what my page looks like after the latest update.


(Sam Saffron) #4

Looks like you have broken avatar images


(Jeff Atwood) #5

Do you have any third party (not from Discourse) plugins? If so, disable them…


(Theis Holtz Hansen) #6

Only the one that was installed by default: lazyYT, poll and docker_manager?


(Jeff Atwood) #7

Perhaps a problem with our avatars.discourse.org service? Turn that off in site settings and see if it helps. Search for “avatars” in site settings.


(Theis Holtz Hansen) #8

That did the trick! Thank you very much.


(Sam Saffron) #9

Can you enable it again for a sec and paste a URL here of the broken image?


(Theis Holtz Hansen) #12

All right when I turn external avatars on the profile menu doesn’t work. When it’s off it does. The external link is:

https://avatars.discourse.org/letter/{first_letter}/{color}/{size}.png


(RĂ©gis Hanol) #13

That’s the URL template. Could you give us an URL of an avatar that isn’t working when you enable external avatars?


(Theis Holtz Hansen) #14

This avatar is not showing on the profile page, but you can load it by the link directly:

https://avatars.discourse.org/letter/h/bcef8e/120.png

(RĂ©gis Hanol) #15

Maybe it’s a cache issue. Have you tried clearing your browser’s cache?


(Jeff Atwood) #16

Or your network or firewall (either on your machine, or on your server) are preventing you from loading the images.

Still, the image should show a placeholder there in the upper right since the HTML specifies image size…

<img alt="" width="32" height="32" src="https://avatars.discourse.org/{stuff}/5297_1.png" class="avatar">


(Theis Holtz Hansen) #17

It doesn’t make any difference to clear cache.


(Theis Holtz Hansen) #18

There isn’t any place older. It is just not there. I’m using Digital Ocean could the firewall be preventing the image to load?


(Gerhard Schlager) #19

Maybe some kind of browser extension (e.g. adblocker) is removing it?
If you are using any of those, try disabling them or try using a different browser.


(RĂ©gis Hanol) #20

That’s exactly what happened. The issue was due to the Privacy Badger extension @HerrHoltz had installed on Firefox.


(RĂ©gis Hanol) #21