Backup file not downloaded with .tar.gz extension


(Frédéric) #1

Hello,

I’m testing the backup/restore process, and I found something annoying but non-blocking :

I have configure my discourse instance with the automatic daily backup on S3.

I made a fresh discourse install, created a new admin user, then go to Admin > Settings > Backups > “Allow Restore”, so ready for Restore process.

Then I went to aws.amazon.com, downloaded the latest backup, and tried to upload it on my new instance.

Here is the blocking message :

There has been an error while uploading ‘mydiscourseinstance-2015-04-02-030000.gz’: The backup file should be a .tar.gz archive.

Indeed, the backup is a “.gz” archive.

So I downloaded Z-zip for Windows 7, and created a .tar then a .tar.gz archive, uploaded it on my new instance. Here the welcome message :

mydiscourseinstance-2015-04-02-030000.tar.gz’ has successfully been uploaded.

then … nothing :scream:

“No backup available.” on the backup listing :scream:

How can I restore my instance ?

Thanks for your help !


Hourly backup, only if something has changed
(Régis Hanol) #2

I think your browser changed the extension of the backup when you downloaded it. To fix it, you only need to change the extension back to “.tar.gz”.

As for the uploaded backup not showing up, you’ll need to make sure sidekiq is working by checking you.discourse.org/sidekiq/scheduler and making sure there’s no warning about sidekiq being paused.


(Frédéric) #3

Yes ! You’re right Régis ! :smile:

After changing the extension to “.tar.gz”, I finally could restore the archive. Many Thanks ! (Sidekiq gave no indice)

So I’m facing a new trouble : the restore process didn’t restore my settings : logo url, s3 bucket for backup, baseline, etc, etc, etc

How can I save those kind of information ? If there is no other way, I will make some screenshots :slight_smile:


(Régis Hanol) #4

The site settings are indeed saved in the backup. Due to how we cache them, you’ll need to restart the application for them to show up after a restore.


(Frédéric) #5

Perfect Régis. Many thanks again !


(Jeff Atwood) #6

I’m glad you brought this up because I think I ran into the same thing. Not sure why downloading from Amazon S3 somehow replaces .tar.gz file extension with just .gz … very odd.

@zogstrip should we accept both filetypes here? Is that safe, I have no idea.


(Marcin Rataj) #7

Or maybe just use .tgz instead? :sunny:
It seems to be a generally accepted shorthand for tar.gz:


(Régis Hanol) #8

Just allowed .tgz and .gz extensions for backup files :octopus:

https://github.com/discourse/discourse/commit/babbbc06d1535affce6b5e0280332eb2f28ee542


(Régis Hanol) #9