Backup uploads terribly slow

backup

#1

I can’t restore my backup…
I’m very unexpert… so I’ll explain everything I did before.

I’m trying to get wordpress and discourse on the same machine (by the way, if you have a guide for this specific purpose it would be fantastic)… since I had done some mistakes that I didn’t understand, I’ve reinstalled discourse (with the beginners guide) and then I installed nginx following your howto, and I started to follow instructions to install LEMP and Wordpress with a Digital Ocean guide (but I stopped at apache installation, because I realized meanwhile that the whole guide looked a bit long and I prefer to restore my previous discourse as soon as possible).

Now, I’m trying to upload my last backup discourse file, but it seems stucked at 23%. Its weight is 10.2mb.

I’ve looked for old discussion and I found this: Backup uploads hang at 2% complete
There is said that the cause is a nginx limitation to file size upload… could be my case too? Any help?

Thank you very much for patience!


(Régis Hanol) #2

How are you trying to upload the backup?


#3

Through admin panel (mysite.com /admin/backup), not by terminal!
Actually it isn’t completely stucked, now, after two hours, it reached 26%. But still very strange for a 10mb file!
I tried yesterday too, I had to turn off my computer but it was hanging at similar percentage for hours.


(Régis Hanol) #4

What browser are you using to upload your backup?


#5

Now by Firefox 43.0.1


(Régis Hanol) #6

Weird, could you try in another browser?


#7

I’ve tried also with safari, now i try others browser… Sure can’t be some nginx or apache problem?


#8

I’ve just tried with opera, much faster, but it reaches 29% and then opera closes (I’ve repetead twice)…


#9

“Fixed”, if we can call it…
I’ve removed nginx and now discourse admin panel uploads perfectly my backup file.

So the problem is nginx (for linux newbie like me, obviously) that puts some limitation to uploading…


(Régis Hanol) #10