Blank screen when adding categories to the navigation menu

Currently my forum shows four categories in the side bar. I want to increase that number. When I press the edit pencil button to make the change, my screen turns dark, but I am not presented with any options to make changes. Any clues?


Disregard - I was able to fix using safe mode. Still not sure which component is causing the issue, but at least I have a solution…

Can you share which component causes this if you find out? If it’s at least listed in theme-component, it could be useful to know. If it’s a custom one, that’s less of an interest for this community. :slight_smile:

Checking the browser console for errors can often help pinpoint an issue. And your /logs page may have something. :crossed_fingers:

1 Like

Appreciate the responses - thanks. I have been testing but can’t seem to figure out the issue. I disabled all theme components and plugins, and still have the issue, which is that if I click the categories edit pencil, or the tiny keyboard at the bottom, the screen darkens properly but I’m never shown a dialog. Logs don’t seem to indicate anything wrong, and I can’t tell from the chrome console, either. I get the same behavior in firefox and edge as well.

The one thing that fixes it is to use safe mode. Appreciate any other clues/tips!

then it’s likely a theme, theme component or plug-in. safe mode is like disabling all of them so maybe try that again and add them back one at a time. you could also try the preview button in each theme /theme component to narrow it down.

Disabling all of them, except from server level. So, it helps only if something that operates on devices is broken.

1 Like

if you are the admin, there is also the default navigation menu categories setting to set the global default. the pencil is for individual user to change that list for themselves.

but clearly something is wrong with the category edit button in the navigation menu. what about if you edit tags or another navigation menu section by clicking its pencil icon?

1 Like

Thanks again. I disabled all theme components, plugins and went back to default theme, and I still get the same behavior/issue. I do have admin rights.

When I press the pencil button, I see this in the chrome console

Autofocus processing was blocked because a document already has a focused element.

Not sure if that helps with further clues…

hmmm maybe try incognito mode (or turn off your browser extensions or even try a different browser). :thinking:

also maybe make sure you are running the latest test passed or supported beta version of Discouse? see announcements

Did you manage to pinpoint what was going on in the end?

Unfortunately no - I’ve tried everything and am still having the issue. I’ve upgraded to the latest as well.

I think a similar thing happened in this topic, and it turned out to be Landing Pages Plugin 🛩, if that could be the issue for you too?

For the record, it has happened in rare cases that an installed but disabled plugin caused issues (at least the chat plugin a long time ago, when it was still an external plugin).