Blank topics after import?


(Frederik Bjerggaard Nielsen) #1

After importing data from Vanilla all my topics are blank. If I press the reply-counter (which is correct numbered) I can scroll through the posts, but the main content section is blank.

I get a bunch of these Javascript errors when opening a topic:

Uncaught TypeError: Cannot read property ‘split’ of null

I’m running Discourse commit a6ebe49 (newest upgrade available at the time of writing this)

Please let me know if you need any other information.


(Jay Pfaffman) #2

ITs clearly something about the import. What version of vanilla? The MySQL importer or the other one?


(Frederik Bjerggaard Nielsen) #3

The other one. Vanilla version is 2.1.11

The topic contents are clearly there but just not shown correctly.

It also applies to the autogenerated topics made by Discourse on installation


(Rafael dos Santos Silva) #4

Have you tried safe mode?


(Frederik Bjerggaard Nielsen) #5

Tried enabling safe mode and disabling it all but still the same result - topics come out blank.

Check this screenshot:


(Frederik Bjerggaard Nielsen) #6

@Falco @pfaffman Any other clues? I’m pretty much stuck on this :confused:


(cpradio) #7

If you press F12 to open the Dev Tools, and reload the page, what errors do you see?


(Frederik Bjerggaard Nielsen) #8

I get a bunch of Uncaught TypeError: Cannot read property 'split' of null


(cpradio) #9

What file is it referencing? A screenshot of the error would be helpful.


(Rafael dos Santos Silva) #10

Please share a link to your forum.


(Frederik Bjerggaard Nielsen) #11

@cpradio Screenshot:

@Falco The forum is not publicly accessible at the moment since I’m still working on it on an internal server.


(cpradio) #12

Okay, and you said you are not running any plugins right and zero customizations?

Can you go to Admin > Settings and check the box Only show overriden?

I have a feeling you changed a setting to a bad value. But I’m not 100% certain which one.


(Frederik Bjerggaard Nielsen) #13

This is the overridden settings:

I am using the following plugins:
- git clone GitHub - discourse/docker_manager: plugin for use with discourse docker image
- git clone GitHub - discoursehosting/discourse-migratepassword: Support migrated password hashes
- git clone GitHub - discourse/discourse-spoiler-alert: A plugin for discourse to hide spoilers behind the spoiler-alert jQuery plugin
- git clone GitHub - discourse/discourse-solved: Allow accepted answers on topics
- git clone GitHub - discourse/discourse-voting: Adds the ability for voting on a topic within a specified category in Discourse.
- git clone GitHub - discourse/discourse-push-notifications: Plugin for integrating Chrome and FireFox push notifications
- git clone GitHub - discourse/discourse-staff-notes: Plugin for Staff users to create notes on users
- git clone GitHub - discourse/discourse-backup-uploads-to-s3
- git clone GitHub - discourse/discourse-cakeday: Show a birthday cake emoji beside the names of members on their join anniversary, or their actual birthday -- and a browsable directory of upcoming anniversaries / birthdays.
- git clone GitHub - discoursehosting/discourse-adsense: Google AdSense plugin for Discourse forum

I tried commenting out all those plugins (except the docker manager) and rebuilding the app but with the same result.


(Frederik Bjerggaard Nielsen) #14

@cpradio @Falco @pfaffman
Any other ideas? Things to try?
I would really like to get rid of Vanilla, but this is kinda holding me back :confused:


(cpradio) #15

Did you make a backup and restore from the backup after doing the import? I know that is recommended to cleanup some lingering performance issues.


(Frederik Bjerggaard Nielsen) #16

It was a brand new Discourse installation so I didn’t think of doing the backup thing, but i’ll try that next.


(Frederik Bjerggaard Nielsen) #17

Seems like it was a broken plugin after all, specifically this one:


(Daniela) #18

The author of that plugin is lost in the space for a long time…
A suggestion: before installing new plugins check if the authors are still active here on meta and if the plugins are up to date. Tons of things have changed from 2014 (last commit of the plugin).


(Frederik Bjerggaard Nielsen) #19

I usually do that, but must have skipped it with this one since I was surprised to find it being that old, But good advice nonetheless!