Brand header theme component

I changed the color value of the icons in this component to $tertiary, so it matches each individual theme.

The Instagram icon is perfectly fine, and the FB icon link works perfectly fine, it just isn’t visible.

Hmmm. It still seems like it must be there though. Have you checked with Dev tools to see if it is there? And while you’re at it check the icon color is correctly being applied? Perhaps the FB icon is being overridden somehow.

Can you share a link to the community site?

My Facebook icon setting looks a bit different:

facebook-f,https://www.facebook.com/GlobalNamati

In case of “facebook” & “facebook-f” icons you should add “facebook-f” into the custom font awesome icons setting.

9 Likes

Hey, this worked like a charm! Thank you so much @vinothkannans! This really had me puzzled.

5 Likes

I’m curious, is there some sort of code I can use/edit to move the links to this side of the header?

Ideally with the fa-icons left in place (on the far right). I’d just like to see what it looks like.

I need some help installing this please.

First I tried this

bundle exec rake plugin:install repo=https://github.com/discourse/discourse-brand-header.git
su discourse -c 'bundle exec rake assets:precompile'

Which seemed to work. But the plugin doesn’t show in the Admin area, and I can’t play with the settings :thinking:

Then I tried adding this to my app.yml:

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discoursehosting/discourse-migratepassword.git
          - git clone https://github.com/discourse/discourse-brand-header.git

And rebuilt the container. But I still don’t see it listed where it should.

I see the files are present in /var/www/discourse/plugins/discourse-brand-header, what else do I need to do to get it recognized? The other one (migrate-password) is there…

Thanks in advance for any help.

1 Like

This is a theme component, rather than a plugin. You install it from within Discourse.

Copy the github URL and then go to Settings, customize, themes, components, and click install. Paste the github url there.

2 Likes

Ah cool, thanks. That worked. I didn’t even have to use the Git URL, it appeared in a list and all I had to do was click.

May I suggest to @vinothkannans editing the top post and in the installation instructions, instead of linking to that other page, simply say

In Admin area, go to Settings, customize, themes, components, and click install, then select Brand Header from the list.

Thanks for the help, and for the component. :cool:

2 Likes

yup it’s fixed, thx!

3 Likes

Hi @vinothkannans, not sure why but I have a phantom link hover here. It doesn’t actually click through to anything.

I don’t believe I have anything strange in the settings. Any ideas?

3 Likes

@MarkTuff I pushed a new commit to fix this issue. Please update the theme component to the latest version in your admin panel.

5 Likes

@vinothkannans

Like magic, fixed!

Thank you!

4 Likes

Hi, I just ran the update this morning and now I get an error message at the top of the site “Your site may not work because theme / component Brand Header Theme Component has errors. Disable it…”

This is my first time updating a component, did I miss a step or anything? Any suggested fixes?

Thanks for your time.

1 Like

Have you also updated discourse? Maybe the theme component was updated to work with a change in the software.

Or vice versa, did you update the software but not the theme component? Can’t tell from your post.

1 Like

My discourse was updated DEC 5th.

It might help if you can tell us what version of discourse and the component you are on.

2.4 beta8, and I updated the component 3 hours ago.

I am on the same and am not getting any error message. Others do not see the error so I would not worry if the functionality is working. The error may resolve itself.

2 Likes

The theme component is throwing an error "Brand Header Theme Component" error: Error: "Could not find module @ember/runloop"

@Allted you’re not on 2.4beta8, but on stable (2.3.7). The theme component was updated here and now it is not compatible with the stable branch anymore. @vinothkannans ?

7 Likes