Brand header theme component

It says it was fixed in the source code but I mean I am on the latest discourse and its happening to me.

It says not to add custom code before #main-outlet. Not sure what this means I should delete though. And it says this was fixed

I’m not on latest, so I didn’t mention it, but it’s happening to me, too.

supposedly this fixed it

But its not fixed

Do you think you can submit a github ticket for the jerky header issue given you also have the issue? I have no idea how to do that

No need. Discussing it here will get it the necessary attention.

It’s just as likely to be a problem with this theme component as it is with Discourse itself.

1 Like

The above commit should resolve the issue. Please check it now and let me know. @Jennifer_Abrams @jtbayly

7 Likes

Oh. It’s beautiful. Thx much!

4 Likes

Hey there, so I can’t figure out what’s wrong here:

I have this FB icon typed in correctly,

But it is invisible in the header:

The invisible icon takes me to the correct FB page if I click on it in the header, but the icon simply isn’t visible.

Any thoughts?

Thought: black icon with transparent surround over a black background perhaps?

I changed the color value of the icons in this component to $tertiary, so it matches each individual theme.

The Instagram icon is perfectly fine, and the FB icon link works perfectly fine, it just isn’t visible.

Hmmm. It still seems like it must be there though. Have you checked with Dev tools to see if it is there? And while you’re at it check the icon color is correctly being applied? Perhaps the FB icon is being overridden somehow.

Can you share a link to the community site?

My Facebook icon setting looks a bit different:

facebook-f,https://www.facebook.com/GlobalNamati

In case of “facebook” & “facebook-f” icons you should add “facebook-f” into the custom font awesome icons setting.

7 Likes

Hey, this worked like a charm! Thank you so much @vinothkannans! This really had me puzzled.

4 Likes

I’m curious, is there some sort of code I can use/edit to move the links to this side of the header?

Ideally with the fa-icons left in place (on the far right). I’d just like to see what it looks like.

I need some help installing this please.

First I tried this

bundle exec rake plugin:install repo=https://github.com/discourse/discourse-brand-header.git
su discourse -c 'bundle exec rake assets:precompile'

Which seemed to work. But the plugin doesn’t show in the Admin area, and I can’t play with the settings :thinking:

Then I tried adding this to my app.yml:

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discoursehosting/discourse-migratepassword.git
          - git clone https://github.com/discourse/discourse-brand-header.git

And rebuilt the container. But I still don’t see it listed where it should.

I see the files are present in /var/www/discourse/plugins/discourse-brand-header, what else do I need to do to get it recognized? The other one (migrate-password) is there…

Thanks in advance for any help.

1 Like

This is a theme component, rather than a plugin. You install it from within Discourse.

Copy the github URL and then go to Settings, customize, themes, components, and click install. Paste the github url there.

2 Likes

Ah cool, thanks. That worked. I didn’t even have to use the Git URL, it appeared in a list and all I had to do was click.

May I suggest to @vinothkannans editing the top post and in the installation instructions, instead of linking to that other page, simply say

In Admin area, go to Settings, customize, themes, components, and click install, then select Brand Header from the list.

Thanks for the help, and for the component. :cool:

2 Likes