Bulk Action ‘Append Tags’ not working when tags are restricted

Bulk append tags function is not working after the latest update. I am wondering whether other folks are experiencing the same issues.

Thank you!

1 Like

You might get better help if you add details about whatever you’re doing that stopped working.


I have just given this a quick run-through on my test site (14532ad425) and the Bulk Append Tags seems to be working okay.

  • Go to Latest
  • Open topic select and select a sample of topics
  • Open gear menu and ‘Append Tags’
  • Choose tag(s) and ‘Append’
  • All selected topics are now tagged with those tags

Is there something else that I could try that may be different on your site?


Sorry for not being clear. Here are the steps:

  • Conduct a search using the magnifying icon
  • Select topics
  • Open gear menu and ‘Append Tags’
  • Choose tag(s) → available tags are not showing up (returns “no matches found”)
1 Like

I’ve just tried through the Search list as well and my tags show in the Choose Tags input box, and are then applied when I Append them.

Are your tags restricted in some way? (And does Append Tags work for you from the Latest list?)

1 Like

Maybe try safe mode.

1 Like

@JammyDodger Yes all my categories have " Restrict these tag groups to this category" setting applied to it, but the tag I was trying to append falls within the allowed tag groups. I can add the same tag by going into the thread.

@pfaffman I tried safe mode. I got the same “no matches found”.

I was able to bulk append tags using the same steps before. :thinking:

1 Like

@littleviolette - I too had this issue on Discourse 2.9.0.beta10. I use an advanced filter where I would filter certain types of content and then bulk append tags to that content.

I noticed that some tags would be working but others would not. It turns out that the ones that were not working were part of the Category → Tags Setting:

Having the tags there did not allow me to bulk append an advanced search, even if the tags I was trying to use were from that same category.


This is still an issue.

  • create a tag #example
  • try to bulk add it to topics in a category → tag appears in the drop down
  • add it to a tag group restricted
  • add the tag group as “Restrict these tag groups to this category” for that category
  • try to bulk add it to topics in that same category → tag does not appear in the drop down anymore

This is happening because /tags/filter/search?q=&limit=5&filterForInput=true does not even take the category into account.


Can somebody let me know if this will be addressed in an upcoming update? We’re finding it very frustrating that we cannot append tags after a topic is created. It’s quite an arduous process of going into the tag group, removing the tag from the group, going back to the category, appending the tag, and then going back to the tag group settings to add it back in.

Thanks for your consideration.

1 Like

Gotcha. We’ll be looking at this.


Hi, is there any updates on this issue?
We are restricting the tag groups to each categories and those tags in the tag groups in the specified categories won’t show up as options.


Hi all,

I’ve been looking over this issue again, and it’s definitely a tricky one to solve. The main problem here is that, with the topic bulk “Append Tags” action, you could be potentially appending tags to topics in N different categories.

The only way we can really address this issue is if we only allow selected of restricted tags to happen if all of the bulk selected topics are in the same category. This way, we can:

  • Change the tag search in the bulk action modal from /tags/filter/search?q=&limit=5&filterForInput=true to /tags/filter/search?q=&limit=5&filterForInput=true&categoryId=999
  • Also show some visual indicator in the bulk action modal that only one category of topics is being operated on, something like this (but nicer)

The tag search would then allow you to choose restricted tags. This also would fix this related topic Bulk Tagging offers wrong tags for category .

If there are no objections to this, we can start work on it soon. cc @tobiaseigen


Thanks for looking into this! I am selecting only the topics in the same category, no other topics from other categories are selected.

Did I set something wrong?Any workarounds?
We have manually copied old Known issues posts from the legacy system and wanted to bulk tag them as either known issue or resolved issue.
Thank you for your help!


No you definitely didn’t set anything wrong :slight_smile: It’s just a limitation of the bulk append modal right now, it’s not limiting the tag search results by category. And the only current workaround is to remove the “Restrict these tags to this category” rule before appending the tags and adding them back after.

I definitely think the fix will be as described in my post above since you are confirming you’re only choosing topics inside the same category. Will try and get work on this started tomorrow if there are no other objections from others in this topic.


A fix for this has now been merged :slight_smile:

@Akemi_Nojima , I will deploy your site today so you get these changes.


wow! amazing! Thank you so much!


This topic was automatically closed after 2 days. New replies are no longer allowed.