Bulk Append Tags Not Working

Bulk append tags function is not working after the latest update. I am wondering whether other folks are experiencing the same issues.

Thank you!

1 Like

You might get better help if you add details about whatever you’re doing that stopped working.


I have just given this a quick run-through on my test site (14532ad425) and the Bulk Append Tags seems to be working okay.

  • Go to Latest
  • Open topic select and select a sample of topics
  • Open gear menu and ‘Append Tags’
  • Choose tag(s) and ‘Append’
  • All selected topics are now tagged with those tags

Is there something else that I could try that may be different on your site?


Sorry for not being clear. Here are the steps:

  • Conduct a search using the magnifying icon
  • Select topics
  • Open gear menu and ‘Append Tags’
  • Choose tag(s) → available tags are not showing up (returns “no matches found”)
1 Like

I’ve just tried through the Search list as well and my tags show in the Choose Tags input box, and are then applied when I Append them.

Are your tags restricted in some way? (And does Append Tags work for you from the Latest list?)

1 Like

Maybe try safe mode.

1 Like

@JammyDodger Yes all my categories have " Restrict these tag groups to this category" setting applied to it, but the tag I was trying to append falls within the allowed tag groups. I can add the same tag by going into the thread.

@pfaffman I tried safe mode. I got the same “no matches found”.

I was able to bulk append tags using the same steps before. :thinking:

1 Like

@littleviolette - I too had this issue on Discourse 2.9.0.beta10. I use an advanced filter where I would filter certain types of content and then bulk append tags to that content.

I noticed that some tags would be working but others would not. It turns out that the ones that were not working were part of the Category → Tags Setting:

Having the tags there did not allow me to bulk append an advanced search, even if the tags I was trying to use were from that same category.