Cannot authenticate with installed SSL Certificate


(Chathura Wijesinghe) #1

I installed Discourse successfully and its worked perfectly with out SSL certificate. With SSL certificate I can not authenticate , its returns “Unknown error”

I can to authenticate using Google , Facebook and Twitter too.

How can I fixe this ?


(Jeff Atwood) #2

As you can see, https in in use here and there is no problem logging in. So this is not a bug, but an error in the installation / configuration.

Have you double checked app.yml for errors?


(Chathura Wijesinghe) #3

Thank you for your reply , Its not working on Chrome browser Version 46.0.2490.80 (64-bit). Its working on other browsers .


(Kane York) #4

Anything in the JS console (F12)?


(Chathura Wijesinghe) #5

@riking Yes I can see this error

https://SERVER_URL/message-bus/60395d0bc6a54f61b011e53e3a23c5e4/poll?dlp=t Failed to load resource: net::ERR_CONNECTION_REFUSED

https://SERVER_URL/message-bus/60395d0bc6a54f61b011e53e3a23c5e4/poll? Failed to load resource: net::ERR_NETWORK_CHANGED
application-fd188041fead0f5fd50060c9dd03bedf.js:1 Uncaught TypeError: Cannot read property 'getResponseHeader' of undefined

https://SERVER_URL/message-bus/60395d0bc6a54f61b011e53e3a23c5e4/poll? Failed to load resource: net::ERR_SPDY_PING_FAILED

https://SERVER_URL/message-bus/60395d0bc6a54f61b011e53e3a23c5e4/poll?dlp=t Failed to load resource: net::ERR_ADDRESS_UNREACHABLE

https://SERVER_URL/message-bus/60395d0bc6a54f61b011e53e3a23c5e4/poll?dlp=t Failed to load resource: net::ERR_CONNECTION_REFUSED

(Sam Saffron) #6

hmmm our current config uses HTTP/2 when is the last time you ran ./launcher rebuild app ?


(Chathura Wijesinghe) #7

I did it 4 hours ago


(Jeff Atwood) #8

Did you do git pull before you rebuilt? That is required…


(Chathura Wijesinghe) #9

@codinghorror I just did git pull and rebuilt again . still can not authenticate on Chrome


(Chathura Wijesinghe) #10

I got session error , I can authenticate using Safari and Firefox but not on Chrome


(Jeff Atwood) #11

If it is specific to a browser, sounds like an issue with your SSL cert. Where did you purchase your SSL cert from?


(Kane York) #12

If you click on the failing POST /session request, what is in the “Response” tab?


(Chathura Wijesinghe) #13

SSL cert from startssl