Cannot delete user who is in a group


(Jay Pfaffman) #1

Hey., @jomaxro, working with a hosted customer today we tried to delete a user.

There was a message that the user had posts and couldn’t be deleted, but there were no posts, but the user was in a group. When we deleted the user from group it was possible to delete the user.


Cannot delete user
(Joshua Rosenfeld) #2

Any chance you grabbed the logs from the failed deletion? I can try again, but last I tried on try I was able to successfully delete a user who was in a group on try.discourse.org.


(Jay Pfaffman) #3

Then it must have been gremlins.


#4

I had that same issue:


(Jay Pfaffman) #5

Yeah, but that’s SSO, so only the SSO master can delete users.


#6

Hmm - could be. The user was created via SSO, but added to the group manually in Discourse. I was able to delete him only after removing him from the group.

BTW, the log is posted in the topic I linked.


(Neil Lalonde) #14

Pretty sure I fixed this today. It happens when one of the groups the user belongs to grants a trust level.

The order of dependent: destroy matters. :bulb:


(Jeff Atwood) #16