Cannot disable ssl with discourse-setup (initial simple docker)

Hello,

when I install the simple docker scenario and enter no Let’s encrypt email (because I have a reverse proxy) the resulting installation does not start because it loops in getting the certificate in nginx. I would expect that it does not “comment in” the web.ssl.template and web.letsencrypt, but it does. If i manually remove them and rebuild then it will start with http only as expected.

# - "templates/web.ssl.template.yml"
# - "templates/web.letsencrypt.ssl.template.yml"

However then the ./discourse-setup does no longer work. It complains about the templates “already enabled”…

Also, i can enter “OFF” at the prompt (if a non default letsencrypt notify mail was given), but if i enter it in the YML file the setup does not like it. (It should probably not only check the input but also the current/old value for OFF or at least allow to keep the option empty).

And in case of off (or empty default) it should not enable the letsencrypt and ssl templates, right - or make the tempülates not block the nginx startup if the certificates are empty).

Our default discourse-setup wizard is for standard installs where HTTPS will always be enabled. If you need a different setup you need to manually configure the app.yml file to your specific needs.

2 Likes

In that case you should probably remove the “OFF” handling and clarify the case when you specify no lets encrypt account, since it claims it wont use it in that case.