Cannot enable 2FA after OAuth2 login

First things first, I just wanted to say I’m loving this software. Keep up the great work.

I have forced 2FA for staff on my instance of Discourse. My staff member used GitHub OAuth2 to register/login to his account, and he cannot enable 2FA as it asks for a password. His GitHub password doesn’t work, and there’s no options on 2FA enable prompt to login with OAuth2

The only workaround seemingly is to reset password, and then my staff member can login with username and password (GitHub login no longer works) and then enable 2FA. Though that makes the OAuth2 redundant as it’s removed from the user.

So hopefully OAuth2 login buttons will be added to 2FA enable prompt, or perhaps I missed a setting that resolves this. Thank you for your time, I look forward to hearing from you.

1 Like