Cannot log in after log out Discourse (after have install wp-discourse)


I installed the plugin “wp-discourse” in my WordPress. I connected WP with the speech successfully, although I didn’t test if it worked, it said it was related to my speech. After that, I tried to log out of the speech to see if the users were synchronized because I installed an SSO and two webhooks (one for users and one for topics).

But when I tried to reconnect, it did not work and also when I press the submit button “connect”, it redirects me directly to the WP. While “wp-discourse” tells me that I am no longer connected to Discourse.

Also, I am always in localhost on both (WP and Discourse).

WP: http://localhost/wordpress
Discourse: http://localhost:3000

But when I write: http://localhost:3000/admin/users/list/active

But I cannot continue my navigation as usual. I only got this page:

Thank you in advance to those who will help me :slightly_smiling_face:

1 Like

Running discourse on a port in this way isn’t supported. Nor is the use of localhost. A valid DNS address is mandatory.

If you have enabled SSO then is the fallback.


Is this a development site that you are running on your local computer? That is the only case where you should be using localhost as the site’s domain.

1 Like

Yes I am running on my local computer

That’s great that you have this setup locally. It sounds like there is a configuration problem with your SSO setup. You can disable SSO on Discourse from the rails console. To get to the console, cd your discourse directory and run:

rails c

When the console prompt appears, run:

SiteSetting.enable_sso = false

Once you have done that, you should be able to login to your Discourse site through its login form. Check your SSO settings on Discourse and WordPress. Then re-enable SSO.