Cannot rebuild app due to nameserver DNS issues "could not resolve host"

Ensuring launcher is up to date
Fetching origin
fatal: unable to access '': Could not resolve host :
error: Could not fetch origin
Launcher is up-to-date

And also
curl doesn’t work

Hey Anna! Sorry you’re having trouble. Either github is down, or, more likely, you have a dns or networking problem.

I found some solutions in discourse community but none of them solve my problem.

Maybe I should change my nameserver in resolv.conf but I have no idea this is right or wrong nameserver address.

options edns0 trust-ad

Thanks a lot

It’s not a Discourse problem, so this isn’t the best place to look for a solution.

If you’re going to use the Google name servers then you should remove the other one. Also, in many configurations, Linux will overwrite resolve.conf, so if changing name servers fixes the problem you’ll still need to do a bit more to see that it’s actually resolved.


So you mean I might remove nameserver

1 Like

Should I do something after change nameserver in resolv.conf like rerun docker?

You can try the curl command and see if it works, and if it does, you can try to ./launcher rebuild app

I looked at my test server and found it has like this

options edns0 trust-ad

So I followed that but still not working.

My thought is I changed /etc/ssh/sshd_config file to use ssh remote from my local PC
Changed like
PasswordAuthentication no -> PasswordAuthentication yes

Do you think this change might affect the server?

This shouldn’t affect DNS resolution on your server.

Really have no idea why my server has this problem.

I didn’t really do anything.

My community was running fine, but all of a sudden this happened to me and I couldn’t connect to my website

Sometimes the local dns server gets broken. Replace that with and see if that fixes it.

Have you rebooted lately? Maybe it’s in adding limbo upgrade state.

I had a similar issue recently, try running the following command, then attempt to rebuild.

sudo apt-get update && sudo apt-get upgrade -y

Another option, if the rebuild fails, would be ./discourse-doctor

1 Like

I don’t think Discourse-doctor will be any help here. It’s an OS issue.

Doing an update and reboot is a good idea.

That’s a good point, update and reboot worked for a similar issue I had a few days back.