Cannot upgrade to 2.1.0


#1

Hello,

I operate Discourse for several months on my VPS. It is installed with discourse_docker repository. I have done some upgrades via both web and CLI in the past.

Now I have encountered an issue while upgrading the Discourse from 2.0.2 to 2.1.0. I run these commands (as always):

cd /var/discourse
git pull
./launcher rebuild app --skip-prereqs

Launcher starts to do its job but it failed after several minutes of execution (it is successfull to build and install some discourse components, redis, ruby stuff and so on).

I attached the last part of the output/log of the launcher. The critical (and a bit cryptic) error message is:

TypeError: {:trusted=>true} is not a symbol nor a string

Does anyone understand what’s wrong and what to do to fixed this? I have tried to upgrade several times in last few days and it is still the same.


#2

OK, sorry, I – as a new user – can not add an attachment, so I paste it here:

I, [2018-09-14T20:56:38.727866 #15]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake aborted!
TypeError: {:trusted=>true} is not a symbol nor a string
/var/www/discourse/lib/auth/open_id_authenticator.rb:13:in `enabled?'
/var/www/discourse/lib/plugin/instance.rb:486:in `block in auth_provider'
/var/www/discourse/lib/plugin/instance.rb:298:in `block in notify_after_initialize'
/var/www/discourse/lib/plugin/instance.rb:296:in `each'
/var/www/discourse/lib/plugin/instance.rb:296:in `notify_after_initialize'
/var/www/discourse/config/application.rb:254:in `each'
/var/www/discourse/config/application.rb:254:in `block in <class:Application>'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:69:in `block in execute_hook'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:62:in `with_execution_control'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:67:in `execute_hook'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:52:in `block in run_load_hooks'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:51:in `each'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/lazy_load_hooks.rb:51:in `run_load_hooks'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/application/finisher.rb:75:in `block in <module:Finisher>'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/initializable.rb:32:in `instance_exec'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/initializable.rb:32:in `run'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/initializable.rb:61:in `block in run_initializers'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/initializable.rb:60:in `run_initializers'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/application.rb:361:in `initialize!'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/railtie.rb:190:in `public_send'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/railtie.rb:190:in `method_missing'
/var/www/discourse/config/environment.rb:5:in `<top (required)>'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in `require'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in `block in require'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:249:in `load_dependency'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in `require'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/application.rb:337:in `require_environment!'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/application.rb:520:in `block in run_tasks_blocks'
/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/rake-12.3.1/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => db:migrate => db:load_config => environment
(See full trace by running task with --trace)
I, [2018-09-14T20:56:46.445759 #15]  INFO -- : 
I, [2018-09-14T20:56:46.446028 #15]  INFO -- : Terminating async processes
I, [2018-09-14T20:56:46.446105 #15]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/9.5/bin/postmaster -D /etc/postgresql/9.5/main pid: 1375
I, [2018-09-14T20:56:46.446160 #15]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 1490
2018-09-14 20:56:46.446 UTC [1375] LOG:  received fast shutdown request
2018-09-14 20:56:46.446 UTC [1375] LOG:  aborting any active transactions
2018-09-14 20:56:46.446 UTC [1382] LOG:  autovacuum launcher shutting down
1490:signal-handler (1536958606) Received SIGTERM scheduling shutdown...
2018-09-14 20:56:46.448 UTC [1379] LOG:  shutting down
1490:M 14 Sep 20:56:46.458 # User requested shutdown...
1490:M 14 Sep 20:56:46.458 * Saving the final RDB snapshot before exiting.
2018-09-14 20:56:46.475 UTC [1379] LOG:  database system is shut down
1490:M 14 Sep 20:56:46.687 * DB saved on disk
1490:M 14 Sep 20:56:46.687 # Redis is now ready to exit, bye bye...


FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 1889 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development --retry 3 --jobs 4'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
b0e6d52243d1535da5c21761839fd36c7b9eec2d4ebe2803b2b1060aed08c10e
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(RĂ©gis Hanol) #3

Seems like you have an incompatible plugin. Can you list all unofficial plugins you’ve installed?


#4

Thank you for the reply.

The plugins are:

(sorry, i can post only 2 links in the post)


#5

and the last one:


(RĂ©gis Hanol) #6

Mojeid is likely to be your problem. It hasn’t been updated in 3 years…

Remove it and do a rebuild :wink:


#7

I was afraid you would say that.

I have comment the plugin out and yes, it works. Thank you!

But I need this plugin so I will open another topic (Auth plugin interface in 2.1.0) if anyone helps.

Thanks