Can't connect to own SMTP Service

I am currently trying to set up a host with Discourse in Docker on my home server for testing it out. It’s working quite well so far, the instance is running smoothly.
However, I can’t manage to send the emails via my own server. In principle, sending via a service provider works.

I’m running a own smtpd in the wild. However, I have deactivated the standard ports 465 and 587 for sending via IPv4 in order to restrict port scans. Only port 23456 is open for sending via IPv4.

A check with
root@HomeServer:/Ruby/docker.ruby.discourse# ./discourse-doctor
results in:

==================== MAIL TEST ====================
For a robust test, get an address from
Or just send a test message to yourself.
Email address for mail test? ('n' to skip) []:
Sending mail to . .
Testing sending to using, with plain auth.
======================================== ERROR ========================================
                                    UNEXPECTED ERROR


====================================== SOLUTION =======================================
This is not a common error. No recommended solution exists!

Please report the exact error message above to
(And a solution, if you find one!)

The I tried to connect via telnet, that’s no problem:

root@HomeServer:/Ruby/docker.ruby.discourse# docker exec -t -i 50544a79b91a /bin/bash
root@discourse:/# telnet 23456
Connected to
Escape character is '^]'.
Connection closed by foreign host.
root@discourse:/# exit

The actual configuration in app.yml is:

DISCOURSE_SMTP_ENABLE_START_TLS: true           # (optional, default true)
#DISCOURSE_SMTP_DOMAIN:    # (required by some providers)
DISCOURSE_NOTIFICATION_EMAIL:    # (address to send notifications from)

I also tried to get it running via IPv6 but no chance. Is there any solution to enable IPv6 connectivity within the docker app?
It is now 2024 and 26 years after the protocol was standardized, I have set up my systems with it - everything is running very well.

Thanks for your help!