Can't delete topics?

Hi there,
I’ve installed Discourse for the first time using Docker on a VM via Google Cloud’s compute engine.
Everything is running smoothly (as far as I can see) and I’ve managed to set up the email too and it works fine.
I’m now trying to delete posts both with an admin account and a user account I created (via incognito) and I keep getting a 504 error.

Nothing in the log, but console shows the following:

Any thoughts?

1 Like

Ok this is even weirder.

I have tested it on different browser and with different users, and it still did not work.
I have then tested it on my phone, and it didn’t work either. I then attempted it again using 4G on my phone (instead of WiFi) and it worked!

I now tried it again on my PC using VPN and it worked. So it seems that my ISP is blocking the request to the server?!

Any ideas?!?

1 Like

How big were these topics? The server can’t manage deleting very big topics or too many posts at once. I had this issue once, and deleting smaller blocks of posts worked fine


thanks! It was just a single post topic.

1 Like