Can't focus and type in "reason for editing" text box (iOS)

I’ve had this across multiple versions of Discourse and iOS but here’s a video with the latest iOS and the Meta forum. The first time I went to edit the post, before I did a screen recording, it was jumping all over the place, but the video still demonstrates the problem.

It’s possible to touch the text box to focus on it all right, but immediately the text box disappears and the screen scrolls all the way down. You can still type or use autocorrect but can’t see what you’re typing.


I edited the post above and the reasons box worked fine. It seems that it works for the first post in a topic but not replies. I tried this on some topics and that seems to be consistent – for instance the first and third posts here: Arrange tags using headings on "/tags" page.

1 Like

Thanks for the report!

I can repro the issue on my iPad.


  1. Edit a post

  2. Tap the edition reason button

  3. The window automatically scrolls down

  4. There’s also a vast empty space below the composer, and scrolling up is difficult because touching the screen will easily focus the textarea or the preview.