Can't get incoming mail to poll


(Jay Pfaffman) #1

I’m testing incoming mail for a site. It worked fine in a previous test (though it was with 1.7.x; this is 1.6.1). I turned on the “insecure apps” thing. It was all good.

Now it doesn’t seem to be polling. Before mail was moving to archive when it was checked; now it’s not. I tried changing the gmail setting to “mark as read;” it’s not marking as read either.

I’ve tried on both a production site and on my dev host. Neither seems to be polling. When I click the “poll via POP3” it does the check and appears to be authenticating (if the password is wrong, I get an error).

I thought it might be that I have “Prevent Discourse from sending any kind of emails” checked, but it’s unchecked on my dev box and I peeked at the source and it doesn’t appear that polling is affected by that setting.

Here is a screenshot of all overridden changes. Am I crazy?

Have I overlooked something?


(Matt Palmer) #2

Seems like it should work. Places to check for more info on what’s going on:

  • Admin -> Logs -> Error Logs
  • Admin -> Emails -> Received
  • Admin -> Emails -> Rejected

The last two are places where an e-mail, if it is received, should end up – no incoming e-mail should not show up in one of those two places.

If all else fails, it’s time for tcpdump:grinning:


(Jay Pfaffman) #3

It finally came in. Maybe Sidekiq was not running.


(Jeff Atwood) #4