Can't Increase the Max File Size


(Kyler Boudreau) #1

Hey, I’m trying to increase the max file upload size on my site. I edited my config file per the instructions here:

https://meta.discourse.org/t/changing-max-attachment-size/26435

I rebuilt the app and then my discourse went down. So I removed the lines and rebooted the server. Back up now, but still now sure on how to do this.

Can someone tell me exactly what file to edit? I had Discourse.org install my forum on a Digital Ocean droplet, so everything is standard. Thanks!


(Joshua Gonzales) #2

You can SSH into discourse while you’re SSH’ed into your Droplet. From there, you could nano /etc/nginx/conf.d/discourse.conf and edit the file directly.

Or I guess you could also copy the file from inside discourse to your host server,

$ scp discourseIP:/etc/nginx/conf.d/discourse.conf ~/discourse.conf

edit the file, and then scp it back into the discourse container.

$ scp ~/discourse.conf discourseIP:/etc/nginx/conf.d/discourse.conf

Either way, once you’ve edited the file, you would have to tell the contained instance of nginx to reload its configuration, like so:

$ docker exec discourse nginx -s reload

#Update

It turns out that there’s a parameter for it in the *.yml configuration. Just add upload_size: 5000M.

Source: Changing Max Attachment Size


(Diogocsc) #3

how do we know the ip of the discourse ?


(Diogocsc) #4

I already saw in Advanced Troubleshooting with Docker that we can use ./launcher enter app to access discourse docker instance.


(Sam Saffron) #5

This is all documented in this howto:


(Sam Saffron) #6