Can't restore backup from business 7 to fresh install due to version error

I have a freshly rebuilt container that is refusing to restore a backup taken hours ago from

Your branch is up to date with 'origin/tests-passed'.

nothing to commit, working tree clean
root@meshack-five:/var/www/discourse# git log
commit c758e2cdd17cc7f8cc44596e72d60e81b5bd8def (grafted, HEAD -> tests-passed, origin/tests-passed)
Author: Joffrey JAFFEUX <j.jaffeux@gmail.com>
Date:   Fri Jan 14 15:51:31 2022 +0100

But when I try to restore, I get …

Copying archive to tmp directory...
Unzipping archive, this may take a while...
Extracting dump file...
Validating metadata...
  Current version: 20220107014925
  Restored version: 20220112091339
EXCEPTION: You're trying to restore a more recent version of the schema. You should migrate first!

I tried doing a SKIP_POST_DEPLOYMENT_MIGRATIONS=false rake db:migrate to see if that would help, but no joy.

https://five.imports.literateforums.com/ shows

    <meta name="generator" content="Discourse 2.8.0.beta11 - https://github.com/discourse/discourse version c758e2cdd17cc7f8cc44596e72d60e81b5bd8def">

Source on the hosted site (on business7) shows:

   <meta name="generator" content="Discourse 2.8.0.beta11 - https://github.com/discourse/discourse version 6272edd1219652a8e1c9c33e16229b029cec603c">

I checked the commits at Commits · discourse/discourse · GitHub and it looks like my server is more up to date.

I feel like I must be doing something stupid, but I can’t see what it could be

3 Likes

Probably just a migration from a plugin that isn’t installed on your system. Replacing the version number in the filename should solve it.

4 Likes

Aha. I was wondering about plugins and whether I needed to install them all. And renaming the file is embarrassingly simple. :man_shrugging:

That worked, but I’ll rebuild with the plugins likely to be at play in case something needs to be there when I merge these two sites.

Thanks very much.

5 Likes