Can't run the launcher to install Discourse on CentOS 7

I know. But I have Centos 7, and I can’t find a tutorial that works without an error. ;p.

Ok, so now I’m getting this error.

which: no docker.io in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/                     bin)
which: no docker in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin                     )
Device "docker0" does not exist.
info: Writing node (dir)Top...
info: Done.
Your Docker installation is not using the recommended AuFS (union filesystem) an                     d may be unstable.
If you are unable to bootstrap / stop your image please report the issue at:
https://meta.discourse.org/t/discourse-docker-installation-without-aufs/15639
./launcher: line 99: --version: command not found
ERROR: Docker version  not supported, please upgrade to at least 1.2.0, or recom                     mended 1.2.0

All I did was yum install docker
(I’m on Centos 7)
Can you just send a link to a tutorial?

I don’t have one… my recommendation is to drop CentOS and use Ubuntu Server, following our standard install guide. It’s all the same Linux underneath anyway.

Here is how you install Docker (logged in as root) in our guide:

wget -qO- https://get.docker.io/ | sh

Error when I do wget -qO- https://get.docker.io/ | sh

Either your platform is not easily detectable, is not supported by this
installer script (yet - PRs welcome! [hack/install.sh]), or does not yet have
a package for Docker. Please visit the following URL for more detailed
installation instructions:

https://docs.docker.com/en/latest/installation/

y u no work launcher

And I can’t. My other dev uses it. Probably gonna buy the $5/mo here. If I just run Discourse on that, (with all of it’s requirements) and Ubuntu, will it work smoothly? Pricing on DigitalOcean - Cloud virtual machine & storage pricing

No, 1GB RAM is required for a live site. 512mb is OK for single user testing only.

I just bought another VPS.
It’s from OVH.
It has Ubuntu 14.04
It has all of the requirements. Followed this: http://www.howtoinstalldiscourse.com/how-to-install-discourse-on-ubuntu/ tutorial.

AND I GOT THE SAME DAMN ERROR.

Device "docker0" does not exist.
time="2014-12-13T14:49:23-05:00" level="fatal" msg="Cannot connect to the Docker daemon. Is 'docker -d' running on this host?" 
Cannot connect to the docker daemon - verify it is running and you have access

Do you have Skype or something? If your able to install it for me, that would be great, because I don’t want to waste any more money on VPS’s. I also don’t know how to remove the old Docker/Discourse.

I REALLY need help here.

Please for the love of God stop using those third party guides that are not official.

Use our official guides only. There is one for Ubuntu. (Make sure it is 64 bit 14.04 server LTS)

Alternately sign up for the $99 install on our buy page.

1 Like

I already tried your guide. I got the docker -d error on the wget docker command.

For both CentOS 7 and Ubuntu 14.04

Search here for OVH.

Try posting on https://forums.docker.com/ and mentioning @SvenDowideit, Docker is meant to be trivial to install everywhere, if the official documentation is somehow broken at Redirecting… this needs to be fixed ASAP.

Docker provides instructions for how to install Docker on CentOS7: https://docs.docker.com/installation/centos/

Roughly:

curl -O -sSL https://get.docker.com/rpm/1.7.0/centos-7/RPMS/x86_64/docker-engine-1.7.0-1.el7.centos.x86_64.rpm
yum localinstall --nogpgcheck docker-engine-1.7.0-1.el6.x86_64.rpm
service docker start

Then to test:

docker run hello-world
3 Likes

To be clear, the root issue here is super low cost hosting with partial virtualization which uses an old Linux kernel on the host that is incompatible with any filesystem Docker supports – realistically (and sadly) only aufs at this point.

Over time old kernel versions should fall away and at least one bleeding edge Union file system will make it into Linux proper.

2 Likes

try
systemctl start docker.service

3 Likes

In case anyone finds it handy in future:

On CentOS 7 try linking the non-existent docker.io binary to the existing docker binary as follows:
ln -s /usr/bin/docker /usr/bin/docker.io

This did it for me just now…

1 Like

Worked. Somehow this should come up as the right answer.

1 Like

Exactly. If it says docker isn’t running, just do a service docker start and move on. That’s what I did.