Docker 1.2 and CentOS 6.5


(jimmy) #1

Hello. I wanted to test out Discourse on my local testing server (CentOS 6.5). Followed all the docs for the install but I’m having an issue with the Docker install. Basically, I can’t get the needed version of Docker to install even after I added the extra repos. Seems that only 1.1.2 will install and not the 1.2 that is needed to run Discourse.

So, I’m at a roadblock setting it up. Any idea how I can get the 1.2 version on my testing server? I even tried to download the 1.2 rpm and that gave me an issue installing.

Any help would be much appreciated.


Installing discourse on centos/apache and bridging with PHP script?
(James Milligan) #2

What errors did you get when you ran wget -qO- https://get.docker.io/ | sh ?


(jimmy) #3

Either your platform is not easily detectable, is not supported by this
installer script (yet - PRs welcome! [hack/install.sh]), or does not yet have
a package for Docker. Please visit the following URL for more detailed
installation instructions:

https://docs.docker.com/en/latest/installation/

Before I was just trying to install docker from the docker site. So, I believe I was doing it wrong.

What I think I’m going to do is just create another VM with Ubuntu and then I’ll probably be able to follow the DigitalOcean install instructions much easier. I was just trying to add it to my existing CentOS testing server, but it looks like it might be easier to just create a new VM for Discourse on my machine.


(James Milligan) #4

Yep, I’d start from scratch if possible.

Did you have a look at the Docker docs here?


(jimmy) #5

Yea, that’s what I used to install it on CentOS 6.5 It actually installed fine per those instructions. The problem was that it installed 1.1.2 and Discourse requires 1.2 +. No matter what extra repo I added I couldn’t get it to update to 1.2.


(Kane York) #6

What happens if you hack the version check out of launcher? I don’t remember what required version 1.2, so…


(jimmy) #7

I don’t have time to hack it to get it working… I run several sites and a few large forums. I just want to get a copy of Discourse working and see what it’s all about so I can decide if I want to migrate to Discourse.

I happen to use CentOS for everything, but setting up a VM for Ubuntu to get things working and moving along is not a problem.


(Jason Ives) #8

Running CentOS 7 I was even more out of luck – no EPEL package and Red Hat provides docker 0.11.1! You can build the latest version of docker using docker, though!

docker run -i -v /usr/bin:/target dockerimages/builddocker

Will build the latest version of docker and place it in /usr/bin – replace /usr/bin with another directory if you’d like and move it from there. When I built it builddocker gave me docker-1.2.0-dev – remove the old docker binary and link (or move/copy) the new one in its place.

Not ideal but until EPEL provides a newer version this may be the best you can do. For what it’s worth docker built using that image has been quite stable for me.


(jimmy) #9

I setup an Ubuntu VM but I’m getting this error when I try to start the app… it’s probably just something stupid.

WARNING: No swap limit support
cid found, ensuring container is started
Error response from daemon: Cannot start container f18324eb77a9993261839343f04df53334ee993283c0651cb596e83c9d94f6ee: Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
2014/10/22 14:39:06 Error: failed to start one or more containers


(James Milligan) #10

Uninstall Apache - the error you’re getting is because Apache is already installed and running on port 80.


(jimmy) #11

Thanks! I guess I should have looked at all the stuff when I installed Ubuntu. LOL! I appreciate the help!


(jimmy) #12

Bingo! Works like a charm.