Can't stop container


(无限星辰) #1

``
Stopping old container

  • /usr/bin/docker stop -t 10 app
    ``
    This takes forever, any ideas how to solve it?
    I tried to restart the docker service & Physical Server but I still can’t stop the container.

I just find this:
Continuing the discussion from Runsv hanging on Docker container shutdown:

but, if I can’t stop old container how can I rebuild with the new image?


(Felix Freiberger) #2

Reboot your machine so Discourse is running normally.

Run docker ps to get the container ID. If there are multiple, you need to find the right one. Then, run docker kill <id> to kill the container. While stopping is broken, killing works – so violence does help here :slight_smile:

Then, simply rebuild as usual.


(无限星辰) #3

thanks, but,
docker kill also takes forever… :confused:


(Felix Freiberger) #4

Hm, then I’m out of ideas.

Are you certain you rebooted your server beforehand? Any try to stop the container will most likely leave it unstoppable and needing 100% CPU. Killing only worked for me while the container was running normally.


(无限星辰) #5

thanks, I restarted my Physical Server, than worked!