Clicking links is stuck in click tracking, shows ERR_FAILED

In our Community Forum, clicking any link in a post will lead to a site that looks somewhat like this:

A bit more context:

  • This started to happen out of the blue sometime today with no configuration change whatsover.
  • We’ve been on 1.9.0.beta2 for quite a long time and this problem prompted us to upgrade to 1.9.0.beta4. The problem still persists.
  • CMD+Click works as expected, the site is correctly loaded.
  • This does not happen to links to the forum itself.

Example: Go to this post and click the link to StackOverflow in the OP.

Any ideas what we can do to fix this?

It does work for me


Did I miss something in the procedure?

1 Like

Interesting. It also works for me in an incognito tab, both as a anonymous user and signed in. It still doesn’t work in a normal tab, even with AdBlocker turned off.

Might this be a cache thing? Browser extension?

I boiled it down to the following:

Visiting the URL in a normal tab doesn’t work for me.

Visiting it in an incognito tab works.

It works for me again, after using the “Clear site data” in the Chrome DevTools:

As this problem has been reported by many other users of the forum, I wonder what the root cause of the issue is.

Try in a different web browser, one you do not normally use. This rules out a number of things.

I will do so. Unfortunately, after two days of using the forum in Chrome, the problem reappeared. I’ll try using Safari instead and will report back once I know more.


Is there any update on this? This problem is occurring in Google Chrome which 90% of our community uses. We’ve already rebuilt the forum a couple of times. We’re running on v1.9.0.beta4 +196.

This is still an issue, with more and more people reporting it every day. So I decided to disable click tracking for now, but I can’t seem to find the option in the settings:

I already removed the code from ga universal tracking code, but clicking on a link still forwards to /clicks/track?url=<url>.

How can I disabled click tracking entirely?

I wonder if this is some how related to your proxy and subfolder setup


Thanks a lot for the hint, @sam!

I wasn’t related to the proxy setup but to the fact that we’re using service workers on the root domain. We’ve disabled service workers for now.


Service workers won’t do so hot with a subfolder setup. While service workers do have some path scope segmentation, it doesn’t work very well - you should just split the forums out into their own subdomain if you want to use service workers.


Thanks @schickling, could you please give us more information about how you solved this issue?

We are facing the same error message on any link of our forum (we are new in forum admin). In addition, we found out that https links work whereas http won’t (for instance the latest link of the latest post of this topic :

We are unsure about how to “disable service workers”. Should that be done on the server side? or on any client machine? Could anyone give us some more information about that?
Thank s lot in advance!

Well step 0 here is enabling HTTPS, it is free and easy to enable should work.

@tgxworld can you think of any internal bug where we ship service worker to non https domains?

We have checks in place to not register the service worker if the site is non https. However, that is just to avoid doing extra work since the browser would disallow service worker registration if the site is non HTTPS.


Thank you so much.
We followed the instructions from @tgxworld : Setting up HTTPS support with Let's Encrypt
in order to enable https and it does now work just fine!!


This topic was automatically closed after 45 hours. New replies are no longer allowed.