Client does not have permissions to send as this sender


(Riccardo) #1

Hello,
I’m not able to send email. The admin email has been activated manually.
When I try to send an email a get “Client does not have permissions to send as this sender”

Here there is my app.yml config:

DISCOURSE_SMTP_ADDRESS: "smtp . company . it"
DISCOURSE_SMTP_PORT: 25
DISCOURSE_SMTP_DOMAIN: "company . it"
DISCOURSE_SMTP_USER_NAME: "COMPANY\\XX021885"
DISCOURSE_SMTP_PASSWORD: "Aaaaaaaa-aa8"
DISCOURSE_SMTP_AUTHENTICATION: "login"
DISCOURSE_SMTP_ENABLE_START_TLS: true
DISCOURSE_SMTP_TLS: false
DISCOURSE_SMTP_OPENSSL_VERIFY_MODE: false

The discourse.conf in app contains:

smtp_user_name = COMPANY\XX021885
smtp_enable_start_tls = true
developer_emails = email@company.it
smtp_port = 25
smtp_password = Aaaaaaaa-aa8
smtp_address = smtp . company . it
smtp_tls = false
smtp_openssl_verify_mode = false
smtp_authentication = login
smtp_domain = company . it

Additional info. This my my gitlab configuration for rails, which is very similar:

gitlab_rails[‘smtp_enable’] = true
gitlab_rails[‘smtp_address’] = "smtp . company . it"
gitlab_rails[‘smtp_port’] = 25
gitlab_rails[‘smtp_user_name’] = "COMPANY\XX021885"
gitlab_rails[‘smtp_password’] = "Aaaaaaaa-aa8"
gitlab_rails[‘smtp_domain’] = "company . it"
gitlab_rails[‘smtp_authentication’] = "login"
gitlab_rails[‘smtp_enable_starttls_auto’] = true
gitlab_rails[‘smtp_tls’] = false
gitlab_rails[‘smtp_openssl_verify_mode’] = 'none’
gitlab_rails[‘smtp_ca_path’] = "/etc/ssl/certs"
gitlab_rails[‘smtp_ca_file’] = “/etc/ssl/certs/ca-certificates.crt”

I’ve tryied to run the test email script from console, but I get error

root@discourse-app:/var/www/discourse/script# ruby test_email_settings.rb
/usr/local/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- action_mailer (LoadError) from /usr/local/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:inrequire’
from test_email_settings.rb:3:in `’

I need help, definetely!

Thanks, Riccardo

PS: I added spaces in code examples just because the “2 links policy” for posting here for the first time in discourse


(Felix Freiberger) #2

This error message appears to be coming from your SMTP server, which rejects Discourse’s emails because of the FROM address Discourse uses.

Please look at the site setting notification email (in Admin → Settings). Can you manually send an email from this address via the SMTP credentials you provided in app.yml?


(Riccardo) #3

Thanks, you are right.
I modified ADMIN | Settings | notification email with the right email to user (previously noreply@…) and now it is working

Riccardo


(Régis Hanol) #4