Command Shift Return is inconsistent

I know this is a small thing, but you’ve already fixed all the big ones.

In Superhuman, command-shift-return replies to a message and then marks the conversation done.

In Discourse, the same keyboard shortcut works in ending a response to a thread.

So my brain, addled as it is, uses it in both places.


If you compose a DM in Discourse and end with command-shift-return, it seems to simply delete everything you just typed, without warning or recourse.

Given that the DM UI is so similar to the thread UI, they should probably behave the same, or at the very least, the DM should prompt with a “are you sure?”

I know this is a tiny quirk that probably only bothers me, but wanted to mention it.

Thanks for everything.


Thanks heaps Seth for reporting.

This certainly sounds very frustrating, I just tested on Linux+Firefox and am not getting a repro.

Created a DM to myself, CTRL-SHIFT-ENTER and it posted, then replied and posted.

I am wondering if we have a Mac quirk here. What browser are you using? (Safari?)

I think our first port of call here is confirming someone on Mac is able to reproduce this.

We will get this sorted, for sure!

1 Like

running Chrome on a macbook m1

on my keyboard, it’s ⌘ SHIFT ENTER


I see, we tried Chrome on Mac and had no luck reproducing the issue. Is there any chance this is browser plugin related? Can you give it a shot in Safari as well?

just opened Safari

just tried to send you a DM

I don’t think you’ll get it, because the same thing happened!


Oh odd I got both the DMs you sent?

We are going to get to the bottom of this Seth, I promise, just trying to get a repro here, we have quite a few on M1 macs so we should be able to figure this out.

1 Like

Actually @Seth_Godin I think I have a repro. We are not navigating you to the PM you are creating so it can feel like it was sent into the void and eaten.

This should be easy to sort out, will keep you posted.



you got them?

that’s great news. So it’s probably user error

but when I go to my activity under my picture, it doesn’t show…

sorry if I’ve wasted your time.


Hi Seth,

I am working on the issue you described and it should be fixed in next few hours.

Meanwhile the messages you sent should be visible at /my/messages/sent.


Here’s the PR:

Awaiting @sam’s review.


Please don’t feel bad here Seth, you certainly did not waste our time, it was a great catch and indeed an oversight in a “hidden feature” we have.

The full context here is that we used to have this feature called “disable jump”.

This feature was critical to specific users who really hated losing the spot in the topic when they posted a reply. A specific place this was fairly critical was very long “movie/episode spoiler” like discussions, by posting they would be transported to the end of the topic and completely lose place.

As a compromise we added a hidden feature where “shift” would signal us:

Hey, I am a power user, don’t navigate me anywhere after I post, I know what I am doing.

The oversight here is that we only ever intended for this feature to work on existing topics, not be used when creating new topics and messages.

The fix was that we get to keep everyone mostly happy. We still jump regardless when you hit SHIFT and are creating a new post or topic, cause it makes no sense to have the bypass there. We keep the jump bypass when you are on a topic/message.

Hope this makes sense and thanks heaps for bearing with us!

Fix is deployed here, full context and history is at:



This topic was automatically closed after 16 hours. New replies are no longer allowed.