Comment Embed Isn't Working - How to troubleshoot?


(Kirupa Chinnathambi) #1

Hello,
This is somewhat related to a question I had last year. I’ve noticed that I am unable to get the Discourse embedding to work on this particular page: Getting the Mouse Movement Direction | kirupa.com

The strange thing is that my logs don’t show any errors either. It is just that the forum topic isn’t getting created when the page loads. Assuming this is related to the encoding issues I had in the past, I verified that the encoding is UTF-8 via the W3C Validator. I also tried saving the page with a BOM as well as without a BOM specified. The discussions still don’t load any more. I tried creating a new document and using the same markup in case converting an existing document might have some issues - same end result.

Does anybody have any suggestions on what I can do to help identify the problem?

Thanks,
Kirupa


(Robin Ward) #2

Can you make sure you are on the latest beta or master of discourse? An older beta had a regression where embedding didn’t work. If it still doesn’t work, please double check your embeddable_hosts setting and make sure it has the correct host.


(Kirupa Chinnathambi) #3

Upgrading to the latest version fixed it! Thanks :stuck_out_tongue:


(Jeff Atwood) #4