Composer previews not working in Safari

On my Discourse instance the preview on the right side of the composer is no longer showing up in Safari:

This started maybe a few weeks ago, perhaps around the time I upgraded to 3.1-beta6 or so, but I’m not certain about the timing.

I’ve also noticed that the content of (I think) queued posts aren’t showing up when reviewing, either. Other posts (flags, etc) that have already been posted show up as normal when reviewing.

It all works fine in Chrome and iOS Safari, and also here on Meta in Safari.

In terms of debugging I’ve tried Safari on other computers, with different ISPs, with other user accounts, etc. The issue persists across all of them.

I’ve also tried disabling all plugins, but no dice. No significant changes done to the site recently (in terms of plugins, CSS work, etc).

I do see two errors in the console when opening the composer in Safari, but not sure if it’s relevant (it doesn’t show up in Chrome or on Meta):

Anyone got further ideas for how to figure out what’s causing this?

1 Like

Does the same happens under safe mode ?

1 Like

Yes, unfortunately it’s still happening with safe mode activated.

EDIT: I’ve now also tried:

  • Disabling all Safari Extensions
  • Switching to an unmodified stock theme with no theme components activated
1 Like

i’m on your forum right now and it’s working

new topic:

reply post:

Safari iOS ipad desktop


Thanks for checking it on your side @Lilly! Definitely a strange issue then. It’s apparently working on my wife’s Mac, too, but not on either of mine (one of which I rarely use, runs an older OS, and is even physically located in a different country). As long as it’s not affecting other users I guess it’s not the end of the world, but still quite annoying.

But whatever is causing it, it may not be Discourse causing it then. Just strange that it works on Meta and not on my forum. I also don’t know what else could be causing it as I’ve disabled every extension or ad blocker etc that’s running on my machine.

Does anyone have any other ideas for what could be interfering with this very specific part of Discourse?


On which version of Safari and macOS are you having this issue?

Can you also post a screenshot of these error messages expanded? A quick Stack Overflow search brings up a very specific Safari issue, so there may more interesting information there.


Now only one error showed up, but here it is expanded:

However, that might be a good hint, as I also ran into this Safari issue when adding in a regex with negative lookbehind recently.

My Safari is at 16.3. I’ll try upgrading it to 16.6 and see if that solves it.

EDIT: I see that negative lookbehinds are only supported from 16.4, so the update should be likely to fix my previous issue—let’s see if this issue is related. However, I’m a bit concerned that my site will be broken for those on older Safari releases, especially when Safari updates are linked to OS updates.

EDIT 2: Upgrading to Safari 16.6 worked:

So I guess I’ll need to make a decision between having the negative lookbehind in a Watched Word regex vs a broken experience for people with an outdated version of Safari…

Thanks for your help everyone! :pray:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.