User edits his last comment, gets "composer was opened without a draft key"


(Lars) #1

One of my users use an iPhone and Safari. When he tried to edit his posts he gets the message “composer was opened without a draft key”.

Some specifics according to himself:

If I try to edit a comment and it happens again, I’ll keep you informed. It actually has happened 5 or 6 times. However, let’s say I go up to another comment in the same thread, I have no issues with editing previous comments. Only happens on the last comment I have made in the thread. Weird!

Link to thread:

I’m on v1.3.0.beta3 +19 (GitHub - discourse/discourse at 399418e1ff186651cedb3044f7d807b8105e670f)


Babble - A Chat Plugin [ARCHIVE]
(Sam Saffron) #2

Weird, we have not seen this one in ages. We have seen tremendous amounts of problems with latest builds of safari on ios so it may be related.

I will have a look to see if there is any extra protection we can add.


#3

Has happened to me too on Chrome beta 42 on Android on meta. I was also editing a comment or so, I can’t quite remember.

Screenshot taken on 2015-03-12.


(Sam Saffron) #4

Can you work out a repro on try, an exact repro would make it easy to solve


(Jeff Atwood) #5

I suspect it is some kind of new regression, we have not seen this in ages but I heard it reported on community.imgur as well recently.


#6

I was able to reproduce it easily:

Create a new thread, editing this post works.
Reply to the OP, the page seems to reload a bit and the composer error pops up after tapping on edit.
This error pops up as many times as you hit the edit icon, reloading the site fixes this.


Post a reply to some comment and the same thing happens as above.


I tried replying to someone else’s comment but editing that works fine. Got the bug replying to an OP. Not sure.



(Sam Saffron) #7

awesome, will fix first thing tomorrow


(Sam Saffron) #8

So this is an android chrome mobile issue only right ?


(Jeff Atwood) #9

Possible, I believe the imgur report looked like Android Chrome to me as well.


#10

Well, OP’s user had this bug appear on his Safari/iPhone.

Can anybody try to repro what I did but on Safari?


(Sam Saffron) #11

this should be fixed per:

https://github.com/discourse/discourse/commit/1d021d701910013665b2baeb7cd353d300f72477


(Sam Saffron) #12