Configuring Discord Login for Discourse

Running discourse 2.6.0.beta5 ( 2686d14b9a )

And encountering this error:

So saved it with that field blank, and when I login via discord, it takes me to where I get I get this:

There doesn’t seem to be any force_https setting

Should I add something to the CORS list?

“Interactions endpoint URL” is not the one you need to configure. You need to add the url to the OAuth2 “callbacks” list:

Once you do that, it should start working as expected :crossed_fingers:


Can this be configured with Discord in such a way so as to not request the guilds scope? I have some users concerned regarding the scope and despite removing all whitelisted guilds (of which there was 1), the instance of Discourse still requests that scope when logging in. Thanks!

I’d say #pr-welcome for us to not request this scope if discord_trusted_guilds is blank on the site settings. What do you think @david ?


Yeah that sounds good to me :+1:


Hmm, when I try to link it with mine, I get this page:

The redirect URI I’m using is

I made sure that I inputted the correct client ID and everything

Not quite sure why this isn’t working, am I missing anything?

Maybe try removing the trailing slash?


Wow. That was extremely simple, I’d been puzzling over that one for a while.


1 Like

Can we test for that trailing slash and remove it or warn about it so this is prevented in the future?

1 Like

That one is set on the Discord side of things.


Yeah we can’t check it automagically, but I just added a little reminder to the OP. Hopefully it will help save some time for future travellers:

1 Like

Just a quick question:
Will this automatically delete/anonymize users that are no longer available on Discord/the whitelisted Discord-Guilds?

Otherwise users could leave the guild or Discord entirely with no option of logging in again thus preventing them from deleting their Discourse account.